GNOME in Manjaro is applying dark mode only to some GNOME apps, not to all

How can I make the dark mode apply to all GNOME apps?

I am using the 2022-07-12 release of Manjaro but hopefully I will upgrade soon.

This should help

2 Likes

I respected all the steps in

I suggest installing the adw-gtk-theme from our community repo to make all Gtk applications have a matching theme. In Tweaks, set the Legacy Applications theme to Adw or Adw-dark. I recommend setting the Shell theme to Default or another shell theme you prefer that has GNOME 42 support.

As you can see below, the setting has no effect:

The thing is that now you have to do that in two places: Settings and Tweaks

Don’t recall if you have to restart the shell, and if you actually have to disable the “User Shell Theme” extension and Night Light … or whatever that auto dark/light theme is called.

I applied your steps and I have the same issue:

Welcome to the wonderful world of LibAdawita. LibAdawita theming was introduced in Gnome 42. You now need a libadawiata theme to control portions of the OS, and a legacy gtk theme for older applications. Hopefully you can find matching ones you like. LibAdawita themes are not plentiful, but some can be found on Gnome Look. The Libadawiate theme is a css theme that goes in ~/.config/gtk-4.0 it will show after a reboot.

@silviubogan
It seems you have “Day Light” mode on. That may cause it. Some extension I guess.
image

If you previously used the Layout Switcher and had the Automatic dark theme ON instead like in this screenshot

Then you updated the system … now the same settings in Layout Switcher look different, like this

but you still probably have that Automatic theme ON …

Also, might not be the exact icon that @raguse mentioned, but maybe yo do have one of this extensions installed and enabled
https://extensions.gnome.org/extension/2236/night-theme-switcher/
https://extensions.gnome.org/extension/4968/lightdark-theme-switcher/

Maybe look for something relevant/related in dconf editor.

1 Like

Exactly as @bogdancovaciu mentions.
From the screenshot in the first post legacy applications (Pamac) do adopt the dark mode, GTK4 not.

Light/Dark mode switcher should look like this below with it’s settings, if you want to use it:
image

image

Best to deactivate all extensions first and logon again and then try.

1 Like