Gnome files takes forever to launch

I click on Nautilus then have to wait 1-2 mins for it to open… This just since last update (I did change the theme but I dont think this could affect…). I’m on an SSD so I dont see how its so slow. Any ideas?

  Host: mazinga-pc Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  Desktop: GNOME 3.36.6 Distro: Manjaro Linux 
  Type: Desktop Mobo: MSI model: Z97-G45 GAMING (MS-7821) v: 1.0 serial: N/A 
  UEFI: American Megatrends v: 2.9 date: 02/16/2016 
  Topology: Quad Core model: Intel Core i5-4690K bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28009 
  Speed: 4000 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 4000 2: 4000 
  3: 4000 4: 4000 
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI 
  driver: nvidia v: 450.66 bus ID: 01:00.0 
  Display: server: 1.20.8 driver: nvidia unloaded: modesetting 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
  Device-1: Intel 9 Series Family HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: Solid Year AWC113 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 2-2:3 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
  Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet 
  vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: 44:8a:5b:9e:1e:a2 
  Device-2: D-Link DWA-171 type: USB driver: rtl8821cu bus ID: 2-14:6 
  IF: wlp0s20u14 state: up mac: 18:0f:76:0a:b6:f0 
  IF-ID-1: docker0 state: down mac: 02:42:ec:ba:9a:83 
  IF-ID-2: ppp0 state: unknown speed: N/A duplex: N/A mac: N/A 
  Local Storage: total: 2.96 TiB used: 830.10 GiB (27.4%) 
  ID-1: /dev/sda vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB 
  ID-2: /dev/sdb vendor: Samsung model: SSD 840 Series size: 232.89 GiB 
  ID-3: /dev/sdc type: USB vendor: Western Digital model: WD10JMVW-11AJGS3 
  size: 931.48 GiB 
  ID-1: / size: 219.27 GiB used: 167.58 GiB (76.4%) fs: ext4 dev: /dev/dm-0 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 1.02 GiB (11.6%) 
  dev: /dev/dm-1 
  System Temperatures: cpu: 47.5 C mobo: 41.0 C gpu: nvidia temp: 56 C 
  Fan Speeds (RPM): cpu: 572 fan-1: 0 fan-3: 1120 fan-4: 0 fan-5: 1057 
  gpu: nvidia fan: 0% 
  Voltages: 12v: N/A 5v: N/A 3.3v: 3.36 vbat: 3.39 
  Processes: 357 Uptime: 4d 11h 53m Memory: 15.59 GiB used: 7.94 GiB (50.9%) 
  Init: systemd Compilers: gcc: 10.2.0 Packages: 1574 Shell: Bash v: 5.0.18 
  inxi: 3.1.05

Run nautilus in terminal and post the output?

Waiting eternally…

Ok actually it does open after some time, but these are the traces (I don’t have this GSConnect extension installed, I only have basic extensions)

Fixed by removing nautilus-typeahead and all its dependencies and reinstalling Files (nautilus). Thx for help Chrys.

That is very odd. By the way, the dependencies are identical for nautilus and nautilus-typeahead. The only difference is nautilus-typeahead contains a patch to enable the search as you type feature that was removed years ago.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.