Gnome doesn't boot after Nvidia Driver installation

Hi, i just installed Gnome with the Installer and everything went fine, after that i did some customization and then i installed the proprietary Nvidia Driver (RTX 3070) and then i rebooted, after that i didn’t got into the OS and got stuck at:

[ OK ] Started GNOME Display Manager .

Sorry i’m completely new to Linux in General and idk what to do :frowning:

Hello there!

Can you get into TTY? When stuck on that messsage, do CTRL + ALT + F2.

1 Like

first i came into this screen after i selected my boot drive (cause i run also windows on my pc):

then i tried CTRL+ALT+F2

How did you go about doing that? If you chose the proprietary drivers upon booting the install ISO, they were already installed.

I used the Non-Proprietary Option when installing the ISO, because when i choosed the Proprietary one i got the same problem. Same happened when i tried Pop!_OS, it only worked and got me into the OS with open source drivers

Yeah this is the TTY,thats Manjaro without GUI in case the GUI is falling,so looks like it boot correctly,just GNOME prevents the boot up
On this screen,can you type

 mhwd -li

to see what drivers you have?

And I think I know what can be the issue,try editing this file

sudo nano /etc/gdm/custom.conf

in there,there is a line


Remove the #,press CTRL + S to save and then CTRL + X to exit,reboot the machine with the reboot command and see if its boot up this time.

1 Like

I don’t think here is a problem. Usually on gnome this should prevent using wayland:


# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"
# disable Wayland when using the proprietary nvidia driver
DRIVER=="nvidia", RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"
# disable Wayland if modesetting is disabled
IMPORT{cmdline}="nomodeset", RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"

Please share your xorg log of the last boot:

journalctl --grep="\([A-Z]{2}\)" --boot=-1 | curl -F'file=@-'

This will print a url on the terminal. Please share this one.

1 Like

um… i just installed manjaro gnome on my ssd (before it was an hdd) and i did the same and first installed with open source drivers and afterwards installed the nvidia driver:

and idk how but then i rebooted and got into the OS with installed nvidia driver, so was the problem that i installed manjaro gnome on an hdd instead of an ssd?

and now i tried it again for validation, but this time it didn’t work?!

i found out what fixed the issue:

first you have to update all packages and then after that install the nvidia driver, but it’s still not possible for me to directly install the iso with proprietary nvidia driver.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.