Gnome Desktop Icons NG (DING) extension not showing settings dialog

I have currently Manjaro Gnome installed on two computers and on both of them I just noticed I can’t get the Settings of Desktop Icons NG (DING) extension. I’m pretty sure it worked in the past. Am I the only one or is it a known bug?

I do as they say “To configure Desktop Icons NG, do rick-click in the dektop and choose the last item: Settings”, but there is no response.

I’m on the recent upgraded Manjaro and I tried to reinstall the extension.

Hello, did you read the recent announcements in the forum?
There are also specific Gnome 40 threads.

With the recent Gnome update, a lot of extensions that worked before, are now bugged or cannot launch at all. As usual with Gnome, I may say.

Check the Stable Update and the Gnome topics to be informed of the evolution of the situation.
The extensions are not developed by Gnome developers. When Gnome is updated (and here it’s a big change), the extensions developers have to adapt their code with the new Gnome version and features.


Thank you, I just read it!
I haven’t figured out I have already the GNOME 40 as neofetch still reports me DE: GNOME 3.38.4 .
So, better to wait till Gnome and extensions stabilize to something useful again :slight_smile:

Yes the Gnome Shell is not in Stable branch yet, so still in 3.38 version, while other components are already at 40.

1 Like
1 Like


Checked the gitlab page. As a novice in linux and Manjaro, not sure - do I understand correctly that the resolution is nigh? :smiley:

Myself, I can cope with the dock for some time, but the desktop shortcuts would be sweet.

Noticed that there is no option in the context menu in Gnome to “add to desktop”. Is there a way to do it or is it not in the GUI yet?

Yet again, cool to see this forum so active and proactive :smiley: :smiley:


I faced the same issue a few days back.

But, the latest update to the extension solved the problem. Be sure to update it :slightly_smiling_face:



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.