Gnome dash to dock not showing mounted volumes and devices

Hi,

I have a simple question: How can I get my NAS (and maybe also my google-drive) to show up in the dock?

The dash to dock extension, has an option to show mounted devices in dock - but my mounted NAS is NOT showing.

  • I mounted my NAS in /media/nas
  • In gnome-files the NAS is showing as mounted device
  • In dash to dock NAS is NOT showing as mounted device (see screenshot)

Additionally I thought my connected google-drive should also show up in the dock, but it isn’t. I remember, when I last used Ubuntu, that my google-drive was showing up in the dock.

Dash to Dock version: 68

Gnome-version:

<?xml version="1.0"?>
<gnome-version>
 <platform>3</platform>
 <minor>36</minor>
 <micro>6</micro>
 <distributor>Arch Linux®</distributor>
 <!--<date></date>-->
</gnome-version>%        

Kernel: 5.8.16-2-MANJARO

Any help is highly appreciated :slight_smile:

EDIT: As stated by @linux-aarhus and @Chrysostomus, it seems that the backend from Gnome is working correctly, and the issue is coming from the dash-to-dock extension. I created this issue on the dash-to-dock github: dash-to-dock is not showing mounted volumes and devices · Issue #1338 · micheleg/dash-to-dock · GitHub

I am no longer familiar with Gnome. One thing I do know is the list is provided by gvfs. Using Thunar as my file manager I have found items stored in the gnome keyring is remembered even the app is no longer installed.

I know because I tested with gvfs-google package on Openbox.

When a successful connection has been made the login is stored in the gnome keyring - and is available to gvfs even gnome-control-center has been removed from my Openbox installation and whether connected or not - it is listed in Thunar navigation pane.

Yes - I know you are using Gnome - nonetheless - my thought is your issue is extension related and my recommendation is therefore to contact the developer using their issue tracker.

1 Like

Since the mounts are working and showing in nautilus, we know that the backend is fine. So the issue is with the dash-to-dock extension.

I can reproduce the issue. It comes likely from upstream, so you might want to consult their issue tracker here:

1 Like

@Chrysostomus Thanks for your answer!
After the response of @linux-aarhus I created this issue today, so the issue you linked is actually mine :slight_smile:
Probably should add that to my initial post.

Thank you anyways though!

Do I need to pick a comment as the solution?
The issue is not resolved yet, but since it appears that this is a bug in dash-to-dock, everything we can do here was creating that issue on github.

1 Like

I figured it might be you because of the similarities, but linked it anyway just in case. I don’t think it is necessary to mark this as solved, as the issue is ongoing, and marking it solved expedites the closing of the thread.

1 Like

So, I just downloaded the source and looked into dash-to-dock because I have nothing to do on a Saturday evening with lockdowns (although admittedly I have absolutely no idea how gnome-extensions work).

One thing that immediately popped into my eye was the following:
Screenshot from 2020-10-31 21-49-05
So it appears that the author of dash-to-dock is purposely NOT displaying network volumes.

Anyway, I deleted those 3 lines, and built dash-to-dock again.
My google-drive is now showing in the dock.

My NAS that I mounted in /media/nas is still not showing up though.
And somehow, when I click on the google-drive-icon in the dash-to-dock, it opens with Code-OSS instead of nautilus :sweat_smile:

So I’m not sure if this is going to get fixed, since it seems as if this is the behavior that is intended of dash-to-dock’s author.

It has worked previously and the ui is still in place, so there is a fair chance it might get fixed.

1 Like

Thats nice to hear! Didn’t know that it worked before, I am a newbie to linux and gnome.

I think the negation has been missed by accident

Instead of

if (volume.get_identifier('class') == 'network') {
    return;
}

It may have been intended to be

if (!volume.get_identifier('class') == 'network') {
    return;
}

@linux-aarhus I don’t think so, since this is the general mount-section of the code.

if (!volume.get_identifier('class') == 'network') {
    return;
}

This code above would probably result in usb-devices (and any other mounted device that is no network-device) to not get shown in the dock.

Admittedly, I didn’t look to deep into the source-code, because I am no expert in gnome-extensions anyways.
It’s probably best to hope that this will get fixed by the dash-to-dock author.

One thing to note: This special handling for network devices is in dash-to-dock since January 2020. The commit message “locations: filter out network volume locations” suggests, that these 3 lines should filter out any network-device, and thats what happens at the moment.

1 Like