Gnome Classic - cant open folders or edit files in GUI as root after update

Hi everyone,
I just updated my system, which I haven’t done in a while, and now when I click “Open as administrator” on a folder or file, I am not prompted for an administrator password. Instead, Gnome immediately displays the error message "Oops! Something went wrong. I am not allowed to access the requested location. "
There is no problem editing files as root in Terminal.

I did google for information on how to fix this, but found most people have a problem with Gnome harassing them about admin password - mine does the exact opposite.

I reinstalled nautilus-admin without any result.

I will be very grateful for any help.

1 Like

Does the following work?

nautilus admin:///root/

Tip: This can also be done from the application location bar/file selector: e.g. in nautilus or gedit, type Ctrl+l and then prepend the admin:// scheme to the resource path. The same effect can be attained via the Other locations server address bar.

See: Running GUI applications as root - ArchWiki

FYI, it’s currently broken with gvfs 1.4.8:

Thank You for response.

Same result - immidiate error

FYI, it’s currently broken with gvfs 1.4.8:

I typed pacman -Qs GVFS and it looks like i have 1.46.2-1 version.

I know. I guess it’s also broken with that version.

So basically the solution to the problem is waiting for a fix in the next update or downgrade of the GVFS package?

It seems that this is not the only problem after the update… The keyboard layout for my language also does not work as it should, and worst of all - WPS Office, which I use for my work. Looks like I have a lot of work to do today

Thanks for the help!

If you have not updated in a while, check the issues and solutions post on the last stable update. There might be some issues you have that are solved, or need some manual intervention. Your keyboard language issue might actually be a locale issue. check out this post

Lots of very strange things have happened. All the options are supposed to be fine, but they just stopped working. The problem with the keyboard is that the right alt needed for lvl3 characters works like the left alt despite properly set options in Gnome. Manjaro Settings Manager → Keyboard Settings and changing the Keyboard Model from Generic to Logitech helped. After clicking Apply, the keys work, but I get the message “Failed to set keyboard layout”. After restart, everything returns to the previous state.
The extra keys also don’t work - xev recognizes them correctly, but you can’t assign shortcuts to them.
It looks like the system doesn’t care about the options set in the gnome.
The printer stopped working, the office programs died … a disaster. All I did is
Sudo pacman -Syu

Can it be undone? I would prefer the old software, but for it to work … Sorry for the panic, but this computer is absolutely necessary for me to work :scream:

After hours of trial and error, it looks like both the GUI support for administrator and keyboard issues are Compiz related. As I can see there has been a transition from compiz-manjaro to compiz-easy-patch. However, I do not fully understand the Compiz relationship with keyboard layout - there is no option to change that in CCSM. It must somehow overwrite it with some default value which is stored somewhere i think.