Gnome Cheese is not able to capture photo or video

Cheese says “There was an error playing video from the webcam”

I have already tried lowering the resolution but it doesn’t work.

I was able to make it work only by using sudo.

This problem persists even when I switch to xorg. As an alternative I used guvcview but it can not record video properly on wayland. It works fine on xorg though.

I am on the 5.15 kernel and the system is up to date. I didn’t have this problem using Cheese 3.38 version. Also, the flatpak version works properly probably because it’s not the latest version.

Is this an upstream problem or specific to my device?

System:
  Kernel: 5.15.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: GNOME 41.3
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 5459 v: N/A serial: <superuser required>
  Mobo: Dell model: 0F1J0W v: A00 serial: <superuser required> UEFI: Dell v: 1.9.0
    date: 09/07/2020
Battery:
  ID-1: BAT0 charge: 29.0 Wh (100.0%) condition: 29.0/32.6 Wh (89.2%) volts: 16.7 min: 14.8
    model: SMP DELL VN3N047 status: Full
CPU:
  Info: dual core model: Intel Core i7-6500U bits: 64 type: MT MCP arch: Skylake rev: 3 cache:
    L1: 128 KiB L2: 512 KiB L3: 4 MiB
  Speed (MHz): avg: 3046 high: 3085 min/max: 400/3100 cores: 1: 3038 2: 3059 3: 3002 4: 3085
    bogomips: 20810
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 v: kernel
    bus-ID: 00:02.0
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile]
    vendor: Dell driver: radeon v: kernel bus-ID: 01:00.0
  Device-3: Microdia Integrated Webcam HD type: USB driver: uvcvideo bus-ID: 1-5:3
  Display: x11 server: X.org 1.21.1.3 driver: loaded: ati,modesetting,radeon
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.15.21-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel
    port: d000 bus-ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-8:5
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 931.51 GiB used: 437.85 GiB (47.0%)
  ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB
Partition:
  ID-1: / size: 83.11 GiB used: 23.14 GiB (27.8%) fs: ext4 dev: /dev/sda8
  ID-2: /boot/efi size: 96 MiB used: 40.7 MiB (42.4%) fs: vfat dev: /dev/sda2
  ID-3: /home size: 85.08 GiB used: 38.15 GiB (44.8%) fs: ext4 dev: /dev/sda10
Swap:
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) dev: /dev/sda9
Sensors:
  System Temperatures: cpu: 53.0 C pch: 46.0 C mobo: 45.0 C sodimm: SODIMM C gpu: radeon
    temp: 51.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 265 Uptime: 1h 56m Memory: 7.66 GiB used: 3.03 GiB (39.6%) Init: systemd Compilers:
  gcc: 11.1.0 Packages: 1439 Client: gnome-shell v: 41.3 inxi: 3.3.12

I also have a problem with Cheese. I’m using DroidCam. The button for taking photo or video don’t response. If I select DroidCam in the settings it does update the picture. (Also, Cheese doesn’t seem to appear in the applications menu (I’m using XFCE).

However, a similar application Kasomo works fine.

1 Like