[gnome]change default screenshot location

I’ve tried changing through the dconf editor

and also by running the command gsettings set org.gnome.gnome-screenshot auto-save-directory "/home/itachi/Pictures/screenshots"

but the screenshots are still saved in the default location i.e $HOME/Pictures

The absolute path is correct, the screenshot folder also exists, and I’ve tried rebooting/logging out but it stills uses the default location.


Hi @zoro11,

According to this page:

Via Terminal

Simply run this command, replacing the path with your preferred directory.

gsettings set org.gnome.gnome-screenshot auto-save-directory "file:///home/$USER/Downloads/"


So, that command, adjusted for you, would be:

gsettings set org.gnome.gnome-screenshot auto-save-directory "file:///home/$USER/Pictures/screenshots/"

Hope it helps!

it doesn’t work, I even rebooted just in case but it stills saves the files to the default location

Please provide the output for:

gsettings get org.gnome.gnome-screenshot auto-save-directory

When providing terminal output, please wrap the text in triple backticks (```). Thet ia looks like:


This will cause it to be rendered like this:


making it much easier to read and work with for those trying to help.

Please also see How to provide good information

~ ❯ gsettings get org.gnome.gnome-screenshot auto-save-directory
~ ❯

That looks right too me. Have you tested it by actually taking a screenshot?

yes, before and after applying the changes but the result were same i.e saved to default location

According to this page:

Note: I have tested this in Ubuntu 18.04 but this works in Ubuntu 20.04 as well.

First disable the default screenshot shortcut from settings:

Disable default screenshot shortcut

Create a custom keyboard shortcut in the settings:

Name it gnome-screenshot, put the command as gnome-screenshot as well

Shortcut value : enter the key [Print Screen]

Create a custom shortcut:

Create a custom shortcut

Now enter into dconf-editor (Install it if you do not have it yet). Go to: org → gnome → gnome-screenshot → auto-save-directory: Change the auto save directory’s custom value to the one you want.

Enter the custom path:

Enter the custom path

If this doesn’t work, it’s possibly because you have a different version of Gnome. Either way, whether it works or not, I’m out of ideas.

1 Like

thank you, this works :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.