GNOME Automatic suspension setting ignored

I’ve disabled automatic suspension at Settings->Power->Power Saving Options->Automatic Suspend:=Off, but somehow it is ignored and the system suspends anyway.

journalctl shows the followings during the suspension process, without explaining how it’s triggered.

gsd-power[..]: Error calling suspend action: GDBus.Error:org.freedesktop.DBus.Error.InteractiveAuthorizationRequired: Interactive authentication required.
systemd-logind[..]: The system will suspend now!
ModemManager[..]: <info> [sleep-monitor-systemd] system is about to suspend
systemd[1]: Reached target Sleep.
systemd[1]: Starting System Suspend...

Is this worth reporting to GNOME? How can I disable automatic suspension before it’s fixed?