GNOME App/Frequently used Menu does not show any application after updating to 3.36

Today I updated the system, but now the GNOME App Menu is not working. When I try to search for any application, it searches forever and nothing shows up. The GNOME shell breaks when I click on "frequently used" button.

All other apps are working well besides these problems. I tried running sudo pacman -Syu gnome and restarted the computer, but got no positive results.

1 Like

Due the change of the shell maybe the way it handless the frequent apps now has new set of strings ...

Reinstalling will not help, because the configuration for Frequent applications for your user is stored in your home user if i recall correctly.
In Settings>Privacy, there is the Usage and History option. It's on by default, but maybe now is off. Switch a couple of times the Recently Used and see if after some time, the list will be populated with applications you use.

What gnome-shell theme are you using? Is this on wayland or xorg?

+1 here, running Gnome with Wayland.

  1. After upgrading to Gnome 3.36, "Show Applications" returns an empty result. My default tab is "All".
  2. Switching from "All" tab to "Frequent" leads to gnome-shell restart.

Update:
Solved by disabling Gnome Extension "Appfolders management extension".
@bogdancovaciu You may try if this works for you.

4 Likes

@Ste74 we should drop this now soon as it is unnecessary now anyway

Already removed automatically with manjaro-gnome-assets-19.0 pkgrel2


so also old installs are safe

1 Like

Disabling the extension worked for me

Worked for me, though Alt+F2 and r were also needed.

I had this on Wayland and disabled Appfolders Management with no joy. Tried sudo pacman -Syu gnome, which handled a couple of conflicts and rebooted, which still didn't work.
I logged out and selected 'Gnome on Xorg', which worked but lost my desktop config. I logged back into Wayland and it now works. :neutral_face:

Disabling the extension worked, thanks

Forum kindly sponsored by