Gnome add printer fails, CUPS lpadmin fails

Hi, I’m trying to install a Brother HL-L2320D to Manjaro 20.2 with Gnome. When using the GUI at Settings->Printers->Add the printer shows up but when I select it a pop-up window announces “Failed to add new printer.”

I tried using CUPS lpadmin by first getting the URI with

lpinfo -v

network beh
file cups-pdf:/
network lpd
network ipp
file cups-brf:/
network socket
network https
direct hp
network ipps
network http
direct usb://Brother/HL-L2320D%20series?serial=U63877E9N778659
network smb
direct hpfax

the I ran lpadmin

lpadmin -p BrotherPrinter -E -v "usb://Brother/HL-L2320D%20series?serial=U63877E9N778659" -m everywhere

lpadmin: Unable to connect to "Brother:0": Name or service not known

Can someone help me understand what is wrong?

Not sure if this helps at all and is a wild gues but try without -E first and enable later?
There is an option to turn on debuglogging, never needed it myself.

Thanks Hanzel. I tried it without the -E and it gave the same error.

Just in case: Did you do the manual intervention following the recent CUPS update? Are you using the Brother HL-2320d driver from the AUR?

localhost:631 in a browser doesn’t work?

1 Like

@jrichard326 I had looked at localhost:631 but didn’t see the section for adding a printer through its interface. I was able to add it there successfully. Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.