Gnome Activities overview background is black

Hey guys,

I wasn't able to find much information regarding a cosmetic issue with gnome I'm having...

However I did run across this post of which sounds similar https://bugs.archlinux.org/task/32347

In theory it has to do with the proprietary Nvidia drivers I'm using, has anyone else run into this issue and been able to resolve it?

System:
  Host: Apollo Kernel: 5.3.7-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Gnome 3.34.1 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
  Mobo: ASUSTeK model: Z87I-DELUXE v: Rev X.0x serial: <filter> 
  BIOS: American Megatrends v: 1204 date: 11/26/2014 
CPU:
  Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 64016 
  Speed: 1300 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 1300 2: 1300 
  3: 1300 4: 1300 5: 1300 6: 1301 7: 1302 8: 1300 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Gigabyte driver: nvidia 
  v: 440.26 bus ID: 01:00.0 chip ID: 10de:1b81 
  Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: gnome-shell 
  resolution: 3440x1440~60Hz 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.26 
  direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Device-3: B & W MM-1 type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 5-1:2 chip ID: 19b5:0004 
  Sound Server: ALSA v: k5.3.7-2-MANJARO 
Network:
  Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:153b 
  IF: eno1 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4352 802.11ac Wireless Network 
  Adapter 
  vendor: ASUSTeK driver: wl v: kernel port: e000 bus ID: 03:00.0 
  chip ID: 14e4:43b1 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 549.21 GiB used: 206.07 GiB (37.5%) 
  ID-1: /dev/sda vendor: Plextor model: PX-256M7VC size: 238.47 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb vendor: Plextor model: PX-256M5Pro size: 238.47 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-3: /dev/sdc type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 14.42 GiB serial: <filter> 
  ID-4: /dev/sdd type: USB vendor: SanDisk model: Ultra size: 57.84 GiB 
  serial: <filter> 
Partition:
  ID-1: / size: 233.72 GiB used: 17.11 GiB (7.3%) fs: ext4 dev: /dev/sdb1 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 42 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:
  Processes: 243 Uptime: 2h 03m Memory: 15.58 GiB used: 1.87 GiB (12.0%) 
  Init: systemd v: 242 Compilers: gcc: N/A Shell: bash v: 5.0.11 
  running in: gnome-terminal inxi: 3.0.36 

That is from November 2012. I doubt that has any relevance in this time and age.
Are you on wayland or x11? Also, what theme are you using for shell and gtk+ ?

Thanks for the reply

Currently under x11 under any theme, I have also tried 418, 430, 435, 440 Nvidia drivers, also from a fresh iso to an completely updated install

Have you tried a custom config from Nvidia X Server Settings? Can you provide:
cat /etc/X11/mhwd.d/nvidia.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 418.88

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Looks ok to me as the default one provided.
Do you use any particular extension that could be related to this issue?

Lets try something:
sudo pacman -R manjaro-gdm-theme && sudo pacman -S gnome-shell gdm
Reboot and let us know if things are the same or better.

$ sudo pacman -R manjaro-gdm-theme
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing manjaro-gdm-theme breaks dependency 'manjaro-gdm-theme' required by manjaro-gnome-assets
$ sudo pacman -S gnome-shell gdm
warning: gnome-shell-1:3.34.1+5+g072a9a484-1 is up to date -- reinstalling
warning: gdm-3.34.1-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (2) gdm-3.34.1-1  gnome-shell-1:3.34.1+5+g072a9a484-1

Total Download Size:    1.92 MiB
Total Installed Size:  13.18 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 gnome-shell-1:3....  1352.6 KiB  2.29 MiB/s 00:01 [######################] 100%
 gdm-3.34.1-1-x86_64   612.2 KiB  16.2 MiB/s 00:00 [######################] 100%
(2/2) checking keys in keyring                     [######################] 100%
(2/2) checking package integrity                   [######################] 100%
(2/2) loading package files                        [######################] 100%
(2/2) checking for file conflicts                  [######################] 100%
(2/2) checking available disk space                [######################] 100%
:: Processing package changes...
(1/2) reinstalling gnome-shell                     [######################] 100%
(2/2) reinstalling gdm                             [######################] 100%
:: Running post-transaction hooks...
( 1/10) Reloading system bus configuration...
( 2/10) Remove capability string of gnome-shell capabilities
A reboot is needed for right activation of desktop-icons extension
( 3/10) Disable night-light feature in GDM

Night-light feature is enabled also in GDM screen, see
here : https://bugzilla.gnome.org/show_bug.cgi?id=785273
for more info.
If you want to disable it please type this command:

sudo -u gdm dbus-launch --exit-with-session gsettings set org.gnome.settings-daemon.plugins.color night-light-enabled false

( 4/10) Gnome GDM theme backup
( 5/10) Manjaro GDM theme install
( 6/10) Compiling GSettings XML schema files...
( 7/10) Reloading system manager configuration...
( 8/10) Reloading device manager configuration...
( 9/10) Arming ConditionNeedsUpdate...
(10/10) Updating the desktop file MIME type cache...

No changes after reboot

What version have you installed, is your system updated ?
From my end:

sudo pacman -R manjaro-gdm-theme
checking dependencies...
:: manjaro-gnome-settings-18.0 optionally requires manjaro-gdm-theme: Branding theme for Gdm

Packages (1) manjaro-gdm-theme-20190929-1

Total Removed Size:  0,99 MiB

:: Do you want to remove these packages? [Y/n] y
:: Running pre-transaction hooks...
(1/1) Remove Manjaro GDM theme
:: Processing package changes...
(1/1) removing manjaro-gdm-theme                   [######################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...

Removed with no problems.

Please then run:
sudo pacman-mirrors -f && sudo pacman -Syyu

I just did a fresh install to troubleshoot with some minor package updates, only a hand full of extensions installed from default are being utilized

user themes
pamac updates indicator
removable drive menu
desktop icons
dash to dock
applications menu

I will update after a full refresh of the package database

$ sudo pacman -R manjaro-gdm-theme
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing manjaro-gdm-theme breaks dependency 'manjaro-gdm-theme' required by manjaro-gnome-assets

Still the case, manjaro-gdm-theme 20190929-1

$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                  149.9 KiB  1743 KiB/s 00:00 [######################] 100%
 extra                1772.0 KiB  12.4 MiB/s 00:00 [######################] 100%
 community               5.3 MiB  25.4 MiB/s 00:00 [######################] 100%
 multilib              184.4 KiB  10.6 MiB/s 00:00 [######################] 100%
:: Starting full system upgrade...
 there is nothing to do

finally got it removed, no changes

This is the issue...

Summary

http://dl.dropbox.com/s/uqxjyrhrdywwxm8/Peek%202019-11-07%2013-45.gif?dl=0

Edit:
So I figured it out, oddly enough it is just my wallpaper that apparently is too dark for the transparency to take affect.

It worked in a previous version of Gnome just fine, so it didn't even occur to me to check.

Forum kindly sponsored by