Gnome 43.2 does not show wireguard config under Network>VPN

First, GNOME 43.2 Manjaro looks really beatiful.

I have a fresh Manjaro install from the Image 3 days ago (Minimal Image/GNOME Version). I want to add my wireguard VPN Connection. How can I do that? In Settings>Network>VPN plus symbol I am asked for a VPN config file!?

What config file format do I need to provide here? Do I miss a package which needs to be installed? As far as I can remember, in the past there was a GUI where I can configure my tunnel.


In NM, wireguard is not considered a VPN, it is its own type. This type is not supported in Gnome Settings. You can install nm-connection-manager and then add a new Wireguard connection. But nm-connection-manager can’t import a wireguard config file.

If you need to import the config, use nmcli . See the Arch Wiki for the correct options.

Thanks. That did the trick. I installed the network manager applet, created the wireguard connection and now I can select the vpn tunnel (above the dark mode switch button).


Yes the panel shortcut for VPNs shows both, VPN connections and Wireguard connections. This is new in Gnome 43, in 42 it would not show Wireguard connections.
Unfortunately, was this was not added in Gnome Settings, it still ignores Wiregaurd connections and don’t let you create one. I hope this will changed in Gnome 44.

Yes, and Gnome Settings asks me for a VPN config file. I am wondering which config files can be applied!? I think it is not the wg-quick config file.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.