Gnome 42 - Broken New screenshot UI

Since the update to gnome 42, the New Screenshot UI is broken for me:

It has no background, the icons look wrong and crammed together and the whole UI seems to be too low compared to the pictures I’ve seen around of this new interface.

To make matters worse, I cannot even use the UI. The “shutter” button cannot be clicked because it occupies the same space as the screen-recording option.

If I use the shift + print-scr key combo, it does take a screenshot an saves it in the expected folder though.

I saw the same issue on a Reddit post. They suggest reinstalling gnome-shell altogether, but this didn’t work for me.

This is what I did, and then rebooted:
$ sudo pamac reinstall gnome-shell
Issue persisted.

They also suggest a corruption of the file /usr/share/gnome-shell/gnome-shell-theme.gresource caused by installing a GDM Theme could be the problem. I’ve installed all sorts of themes before, so this might be the issue for me too, but I have no idea how to restore the original one.

I’ve tried restoring all gnome default setting using this:
$ dconf reset -f /org/gnome/

But the issue with the screenshot UI persists.

Any ideas :frowning: ?

I use X11, mutter 42.1 & nvidia 510 drivers.

pamac uses polkit, no need to use sudo … anyway
Remove manjaro-gdm-theme and reninstall gdm just in case … reboot after that.

1 Like

Your solution worked perfectly @bogdancovaciu, thank you!
Sorry for the dealy, I was out of town for the weekend.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.