Global window menus missing after upgrade

Hi everyone,

switched to Manjaro as my main driver last week, so a fresh install on an AMD Ryzen 7 4800 system.
Did an update on the Manjaro system yesterday, which was massive, pulled in about 1.6 Gb of packages, including going to Kernel 5.9.16 and Plasma 5.20.4.
After this I noticed that the programs are missing the global menu (file, edit, view… etc). Ctrl-M or any other tricks I googled won’t work

I thought maybe it’s because I played with widgets and themes etc, so I created a new user account, but the same thing happens there, no menus.

I assume it has to do with the upgrade

GTK based apps like Thunderbird and Firefox still have the menus, just not the pure KDE apps, Kate, Dolphin etc

I have already rummaged around the .config dir when I googled for this problem. Looked for config files of apps and how their MenuBar is set. For example

~/.config/katerc has:

cat katerc | grep Menu
Show Menu Bar=true
Allow Mark Menu=true
Bookmark Menu Sorting=0

But it still comes up without Menu

~/.config/arkrc has:

cat arkrc | grep Menu

and also comes up w/o menu

When I change the file and set MenuBar to Enabled, and restart ark, it still comes up w/o menu again and the file is also changed back to MenuBar=Disabled

So there seems to be some overarching feature that overrides it.

This is why I thought it had something to do with my fiddling with themes and widgets. Hence I created a new user, but the same problem exists there…

Has anyone else experienced this?

UPDATE: Just solved it when I stumbled across this post: [Solved] Lost menu bar • KDE Community Forums
The last reply fixed it for me:
Three things are required to get your menus back.

  1. cd into your .config folder and execute : find ./ -type f -exec sed -i ‘s/MenuBar=Disabled/MenuBar=Enabled/g’ {} ;
  2. In KDE configurations > Window management > Menu tab > remove burger menu from title bar in both active and inactive
  3. In KDE configurations > Startup > Services > disable the menu damon
    Plus if you want your top menus in kate, hit ctrl+m twice.
1 Like

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.