Global Shorcuts are messed up after the latest update

Hello there. After updating my installation to the latest version (20.1), my Launch Konsole shortcut (Ctrl+Alt+T) stopped working. Swtiching to Defaults removes this and some other shortcuts altogether. Importing a scheme has no effect whatsoever. I tried binding a shorcut directly to Konsole application as well (as opposed to the KDE Daemon -> Launch Konsole) with no success. I don’t know where to start troubleshooting this issue and I would appreaciate any help.


I can confirm that on one of my installs i had the same issue. I added back the Konsole to the list and set the shortcuts for it like this:

It works now, but … Konsole has this option:


So better then use the same in Settings.

Actually, is better to set this way:

Your settings options appear to be a bit different from mine, which are as follows:


Any idea how to fix them in my case?

Try to remove Konsole from the list, apply, add Konsole to the list again, ass application and set again the shortcut then apply.

I must have done it 20 times by now, to no avail.

I’m pretty sure the issue is with my configuration that got partially corrupted after the update, because when I booted up from the live manjaro image, I had no such problem. Perhaps there are some config files that are specific to shortcuts that I can remove?

Ok, booted in my other install, and Konsole is not in the list at all, but when i press the shortcut it works, it opens.


Inside ~/.config/kglobalshortcutsrc i have this entry:

_k_friendly_name=System Settings
{6ad3b755-8deb-4907-a075-f1ddd2f560e3}=Ctrl+Alt+T,none,Launch Konsole

while on my other install i have:

NewTab=none,,Open a New Tab
NewWindow=Ctrl+Shift+N,,Open a New Window

So, is definitely a change in the way this configurations are written/structured. Have a look and try to set them manually.

1 Like

Unfortunately manually modifying the config file did not help. But I noticed that you had a Custom Shortcuts entry, which was missing in my case. After quick search, I relized that I was missing the khotkeys package. After installing it, I was able to get the shortcut working, since the package conveniently includes a pre-defined Launch Konsole entry. Thanks for your support and time!

For info the Konsole shortcut in my KDE is found in another place (I don’t know why but the other shortcuts visible here are actually my own made custom shortcuts which are visible also in the Custom Shortcuts tab, I didn’t create the Konsole one), launched systemsettings5 from terminal so it is not/for the most part not localized so everyone has common ground, it is in the System Settings menu):

And now I wrote that, I verified and you can see my own Custom Shortcuts in their own ‘folder’, and you can see what I kept from the provided custom shortcuts (I deleted everything, and kept only Konsole shortcut).

Not sure what happened/changed since installation to the last update but for me I always had this shortcut.

// EDIT OK I found some weird stuff, in my second screenshot you don’t see it but I deleted one unused provided shortcut before taking the screenshot, which was for “Search” and that was pointing to “”, I went back to Global Shortcuts and Now I don’t see the “Configuration du Système” menu (which was localized in French initially, then in english “System Settings” after switching from Custom/Standard/Global Shortcuts menus), but all the shortcuts visible in screenshot one are now moved to KDE Deamon menu (or a second one KRunner).
After closing and restarting the System Settings, the localization weirdness (by starting systemsettings5 from terminal instead of GUI menu) and the visibility of my custom shortcuts (in other place than the specific Custom Shortcut menu) is reproducible easily. It is unrelated to the initial issue here, but maybe these weirdness could be looked at to find the culprit. It is maybe just a visual glitch but it is weird to me.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.