Global menu does not work for Dolphin and Konsole

Global menu does not appear when I open Dolphin or Konsole.

There are several things you can try…

  • Press Ctrl+M.

  • Click the button above the red arrow in the screenshot below.

  • It may be necessary to switch to another Qt-based application first and then back to Dolphin or Konsole. There is a bug in the global menu widget, and normally it should not affect Qt-based applications ─ it only appears to affect GTK-based applications ─ but it never hurts to try.

When I press Ctrl+M, I can see a menu bar, but it is not on the top panel. The theme I installed doesn’t work on Dolphin neither.

Are you using the standard global menu widget that comes with Plasma or are you using one of the alternative widgets like plasma5-applets-window-appmenu-widget from the AUR?

I have tried the alternatives, and I had the same problem with Konsole ─ I don’t remember whether I also had it in Dolphin, but I do remember that it was also missing the menu in one of the editors. So I went back to using the stock global menu widget, which works.

I am not using any alternative widgets.

Earlier you said… :arrow_down:

Maybe that’s the cause of the problem?

I think the problem is the theme, because the menu worked before I use a theme.

That’s what I was trying to tell you already. :wink:

I solved the problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.