Gl problems after update

Hi I’m running Manjaro Gnome 42.4 X11, after update I’ve these errors:

gdk_gl_window_impl_x11_make_context_current: assertion 'GDK_IS_GL_CONTEXT_IMPL_X11 (glcontext)' failed

cannot create GdkGLContext

gtk_widget_get_gl_window: assertion 'gtk_widget_get_realized (widget)' failed
gdk_gl_drawable_gl_begin: assertion 'GDK_IS_GL_DRAWABLE (gldrawable)' failed


name of display: :1
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  110
  Current serial number in output stream:  111

How can I fix it?
Thank you


I just had the same issue in Ubuntu. I tried many things to fix it, so I am not 100% sure what resolved it in the end.

I think that what resolved it in the end was installing development libraries for libglvnd (libglvnd-dev in Ubuntu, not sure what it’s called in manjaro) and then reinstalling the drivers.
I am basing this assumption on the fact that when I tried to install Nvidia’s drivers using their installer rather than the one included in my distro, the installer crashed and complained about glvnd dev libraries not being present

You can try that and see if it helps. Also, please let me know if it helped because I would also like to know what I ultimately did to fix this issue.