Git in konsole still asking for username and password even gnome keyring working

Hello I am Rajrup ,
I am facing an issue since installation of Manjaro KDE plasma,
my git is not working correctly. i installed gnome keyring for key management , i just started it and every time when i use Visual Studio it’s asks for my passphrase to login ,
my problem is with Konsole git push , when ever i tried to push using Konsole git always asking me for my user name and password , and i don’t know why? because when i push from Visual Studio code it did not asking for the user id and password. but how much i can remember before Gnome keyring installation it also does the same , and some times can’t even give me the chance to push.
where is the problem?
how can i solve the problem.
**i just restup git and sshkeys everything from start and but still it’s asking for id and password . i am saying this because am pretty new to linux env , and in windows i did not faced such, windows is just matter of child just install and go. Linux is for master .
I just tried to push from vs code to a remote repo after all the changes and everything keeps working as before. Where is the issue? why konsole keeps asks for git id and password even i installed and save gnome keyring and inside of vscode it’s working fine not asking for those . **
Please if you know please tell me .
I will be very gladful to you.

What are you using for connection: ssh or HTTP?
Maybe your user, pass, and ssh key are not set for the connection.

Did you set git username and email? Probably not – see current values via git config --list. If this is not set you need set and values:

git config --global "your github name"
git config --global ""

You need also use ssh connection instead http:

nope it’s not working, i reset everything from gnome keyring to git but before using your method it’s not giving me permission to push after doing your steps it still asking for the same

well tell me one thing how can i setup that gnome keyring again i just forgot ,
what did i do last time i just completely forgot.
It’s not very easy to use linux but i can’t gonna quit tho

how to do these things can you tell me please , i want to know

So you don’t have ssh keys in your github account or use https instead ssh. Let’s start from begining:

  1. Create ssh key, you can specify password and key location and name (the default is ~/ssh/id_rsa), add comment or specify other options, see documentation:
ssh-keygen -c "comment"
  1. Add your key to ssh-agent
eval $(ssh-agent)
ssh-add ~/.ssh/id_rsa
  1. Setup your git if you not done yet:
git config --global "your github name"
git config --global ""
  1. Go to your github account settings and add key, you copy here content of ~/.ssh/ file (or other if you specified other option above):
  2. Clone your github repo via ssh:

Gnome keyring have nothing to do here.

1 Like

Yes this is working , i actually missed the last step you said there :grinning_face_with_smiling_eyes:, but i started from the first then follow github documents says then i follow your steps the last cloning method and it’s working now properly . Thanks a lot

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.