Gimp canvas freezes always

When i select any tool and try to do something with it on the canvas, nothing happens, ecxept the mouse gets very juddery.

Does this happen in X11 session too?

i dont kow how to try this.
i tried to startx and to simply run gimp on another tty but this failed.

You added wayland as tag to your topic title, so i assumed you run under wayland session and you know how to switch sessions.
Open up terminal and provide from it:
inxi -Fazy

Also, open gimp from terminal and provide the errors you get. Please format the output text for better reading.

$ inxi -Fazy
  Kernel: 5.15.25-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=6cc17556-5d59-4602-878c-d03a8eb9f4d5 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel, plank
    wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7A38 v: 2.0
    serial: <superuser required>
  Mobo: Micro-Star model: B350M PRO-VDH (MS-7A38) v: 2.0
    serial: <superuser required> UEFI: American Megatrends v: A.60
    date: 09/19/2017
  Info: model: AMD Ryzen 5 1400 bits: 64 type: MT MCP arch: Zen
    family: 0x17 (23) model-id: 1 stepping: 1 microcode: 0x8001129
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1583 high: 2763 min/max: 1550/3200 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2763 2: 1650
    3: 1377 4: 1375 5: 1377 6: 1377 7: 1377 8: 1373 bogomips: 51216
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lexa XT [Radeon PRO WX 2100] driver: amdgpu v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 8 ports: active: DP-3 empty: DP-1,DP-2
    bus-ID: 22:00.0 chip-ID: 1002:6995 class-ID: 0300
  Display: x11 server: X.Org v: compositor: xfwm v: 4.16.1 driver:
    X: loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: DisplayPort-2 mapped: DP-3 model: HP 24es serial: <filter>
    built: 2017 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
    size: 527x296mm (20.7x11.7") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
    bus-ID: 22:00.1 chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 24:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media Audio Adapter (Unitek Y-247A) type: USB
    driver: cmedia_hs100b,snd-usb-audio,usbhid bus-ID: 1-9:3 chip-ID: 0d8c:0014
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.25-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.47 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 1e:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp30s0 state: down mac: <filter>
  Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl
    v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 20:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlp32s0 state: up mac: <filter>
  Local Storage: total: 1.25 TiB used: 95.23 GiB (7.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power
    model: SPCC M.2 PCIe SSD size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: ECFM22.6 temp: 27.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT120BX500SSD1
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: R013 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000VX005-2EZ102
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5900 serial: <filter> rev: CV11 scheme: GPT
  ID-1: / raw-size: 111.33 GiB size: 109.08 GiB (97.98%)
    used: 95.23 GiB (87.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 469 MiB size: 468.1 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 10.74 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 34.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 2019
  Processes: 273 Uptime: 13m wakeups: 0 Memory: 7.78 GiB
  used: 2.19 GiB (28.1%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 1611 pacman: 1600 lib: 427 flatpak: 11
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.13
$ gimp
Gtk-Message: 12:39:51.638: Failed to load module "topmenu-gtk-module"
~/.gtkrc-2.0:1: error: unexpected character ':', expected keyword - e.g. `style'

I just realized it is an x session :man_facepalming: :see_no_evil:

Ok, so you are using topmenu-gtk from AUR, that might need a rebuild once you install the latest updates, but i wonder what custom thing you added to your

Not quite sure how much that will affect things in gimp, but might want to look into it:

I dont use topmenu-gtk because i got it never working.
in fact it isnt installed anymore.
the configuration line was for the module. gimp tried to use the module beacuse of the line, i deleted it.
however, it didn’t solve the problem

Well, you can remove then the file, restart your session and share the newer error you get when opening gimp from terminal.
Not sure also how to interpret this:

Do you have some custom driver installed for your GPU?
Also, never had issues with gimp, but might want to delete, or move the ~/.config/GIMP/ and start gimp fresh …

There is no new error message.
I dont remind to install any gpu drivers.
i solved it by moving the configuration file, i will try to find the wrong setting later this day and post it here.

Thanks for your help so far!
This seemd to be all pretty obivous stuff but i hadn’t really a way of approaching such an issue.

The folder is quite big an i found no suspicious differences at a broad overview. It wasn’t the config file.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.