Ghostwriter: Segmentation fault (core dumped)

Need Help Installing Ghostwriter

  • I installed ghostwriter via pamac gui > ghostwriter appeared in my menu & I put it in my panel.
  • When I clicked the ghostwriter icon in my panel, the ghostwriter window never opened.
  • I uninstalled & reinstalled ghostwriter with the same result: ghostwriter window never appeared.
  • I typed “ghostwriter” into terminal… & terminal replied:
    $ ghostwriter
    Command “pandoc” is not available.
    Command “multimarkdown” is not available.
    Command “cmark” is not available.
    Segmentation fault (core dumped)
  • I don’t understand what this means: “Segmentation fault (core dumped)”
  • How should I install ghostwriter? I could install it via terminal. But before I try that I want to understand why I’m having this problem.
1 Like

You already have it installed.

Those are optional dependencies for ghostwriter. It will run without them. I can’t reproduce the issue.

What version do you have installed? It should be 2.02-1:

pacman -Qi ghostwriter | grep Version 

It means the program crashed. Search the internet for more gory details if you wish.

Make sure you have up to date mirrors and everything is up to date:

sudo pacman-mirrors -f5 && sudo pacman -Syyu

If you’ve recently updated and haven’t rebooted, you may need to do that.

1 Like

I think I found a solution to my problem via google. Last month another Manjaro user published a blog post about fixing the same ghostwriter problem: …Segmentation fault (core dumped):

A Segmentation Fault and a Peculiar Ghostwriter Install on Manjaro
By Nicholas A. Ferrell
August 5, 2021

But this user’s fix requires rebuilding an AUR package from sounce, which is currently beyond my ability. So unless someone can suggest an easier fix, my plan is to uninstell ghostwriter and wait for a newer ghostwriter version which solves the manjaro segmentation fault problem.

So i also had same issue and after searching through google, i found way

  • you have to first install ghostwriter-1.8.1-4 this version and after you can install latest version and it will run without segmentation fault.
1 Like

On that page there are two different versions, which one do I download?

  • ghostwriter-1.8.1-4-x86_64.pkg.tar.zst
  • ghostwriter-1.8.1-4-x86_64.pkg.tar.zst.sig

And then after I’ve downloaded it, how do I install it? I’ve never installed from a downloaded package before.

And after I install it, then do I uninstall it before installing v.2.0.2-1?

This one ghostwriter-1.8.1-4-x86_64.pkg.tar.zst.

  • first extract it.
  • then copy the file in the bin to the /usr/bin and and other file /usr/share
  • then install latest version.
  • I downloaded: ghostwriter-1.8.1-4-x86_64.pkg.tar.zst
  • I extracted this .zst file to: ghostwriter-1.8.1-4-x86_64.pkg.tar
  • I extracted this .tar file to: a usr folder which contained a folder titled “bin” & a folder titled “share”
  • the bin folder contains one file: “ghostwriter”.
  • I suppose that I should copy this “ghostwriter” file into my file system, iinto /usr/bin
  • But the share folder contain 5 folders, and I don’t know exactly how to copy these 5 folders into /usr/share.
  • Should I copy the share folder into /usr/share? Should retitle the share folder “ghostwriter” and then copy it into /usr/share? Should I copy only the 5 folders inside the share folder into /usr/share?

the .pkg.tar.zst is the package, the .pkg.tar.zst.sig is the signature file. You only really need the former.

Open a terminal in the folder where the package is and install it

sudo pacman -U ghostwriter-1.8.1-4-x86_64.pkg.tar.zst

No, it will downgrade or upgrade it in place.

What does that accomplish? Installing the latest version will overwrite the files you just copied manually.

Fiddling around manually placing files in the system? Probably not.

1 Like
  • I put ghostwriter-1.8.1-4-x86_64.pkg.tar.zst into a folder with nothing else in it.
  • I opened terminal and did a cd into that folder.
  • I ran the terminal command that Yochanan recommended, etc.:
    sudo pacman -U ghostwriter-1.8.1-4-x86_64.pkg.tar.zst
  • I went to pamac gui planning to install ghostwriter 2.0.2, but pamac said this version was already installed.
  • But when I opened ghostwriter I saw that I had only installed v.1.8.1.
  • I checked pamac updates & noticed there was an update for ghostwriter.
  • I updated software via pamac.
  • I opened ghostwriter again and saw that the version had updated to v.2.0.2.
  • Now I plan to learn to use ghostwriter …
  • So thank you rathod0045 & Yochanan!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.