Ghost snapshots in Timeshift

Hello, I see a lot of ‘ghost’ timeshift snapshots in Grub when I run sudo update-grub

I cannot see these in the Timeshift application itself, and would like to have them deleted.

Each time I run a system upgrade, Timeshift tries to do an ‘auto snapshot’ and clean up old snapshots - and since it cannot find these ‘ghost’ snapshots, it goes through a long process of trying to delete and failing.

Any suggestions ? Thank you !

I also see them. It’s like, when you remove snapshots, some files stay. It is possible that this is an intentional behaviour - it could be, that the newer snapshots, use the files from removed ones. However, I can be wrong.

Anyway, those old snapshots take a lot of space so I just delete them manually, but leave some “newer ones”, at least few versions before the last existing snapshot. Also, after deleting, I’m doing a new snapshot, in case the deleted folders messed up existing snapshots.

I wish there would be a better documentation for this.

Hi there, I have tried to delete them manually but cannot do so. I get an error “cannot remove xyz file, read-only file system”. Not sure how to proceed.

What file format do you use on your backup source and which type of backup do you use?

I use ext4 and have rsync based backups, so I have full access to my files. Aside having full backup, I often need to reach for certain files within backup, that is why this kind of setup is optimal for me.

Mine is Btrfs

You mean the ghost snapshots are read-only, you can delete them manually.

  1. What is the output of sudo lsblk -f?

  2. Copy UUID of your system.

  3. Mount btrfs root system

sudo mount -t btrfs -o subvolid=5 /dev/disk/by-uuid/{XXXXX-XXXX-XXXX-XXX} /mnt


  1. Delete the timeshift-snapshots what you want.
sudo btrfs subvolume delete /mnt/timeshift-btrfs/snapshots/{DATE}/@

Thank you for suggesting this! I did this and was able to delete the snapshots. They no longer show in the timeshift snapshots folder.

However, they still show up in the sudo update-grub list

Found snapshot: 2021-09-21 09:34:48 | .Trash-0/files/2021-09-21_09-34-48/@ | N/A | N/A |
Found snapshot: 2021-09-21 09:02:23 | .Trash-0/files/2021-09-21_09-02-23/@ | N/A | N/A |
Found snapshot: 2021-09-18 16:52:16 | .Trash-0/files/2021-09-18_16-52-16/@ | N/A | N/A |
Found snapshot: 2021-09-18 13:18:27 | .Trash-0/files/2021-09-18_13-18-27/@ | N/A | N/A |
Found snapshot: 2021-09-18 11:52:59 | .Trash-0/files/2021-09-18_11-52-59/@ | N/A | N/A |

What is output of sudo btrfs subvolume list -p / | grep Trash?

ID 290 gen 389 parent 5 top level 5 path .Trash-0/files/2021-09-18_11-52-59/@
ID 291 gen 500 parent 5 top level 5 path .Trash-0/files/2021-09-18_13-18-27/@
ID 293 gen 807 parent 5 top level 5 path .Trash-0/files/2021-09-18_16-52-16/@
ID 296 gen 3076 parent 5 top level 5 path .Trash-0/files/2021-09-21_09-02-23/@
ID 298 gen 3050 parent 5 top level 5 path .Trash-0/files/2021-09-21_09-34-48/@

Try to delete the trash-snapshots

sudo btrfs subvolume delete /mnt/.Trash-0/files/{DATE}/@

That did the trick. Thank you so much for your patient replies!! Have a great day!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.