Getting wide blurred edges instead of blurred window

Hello there , I am new to the GNU/, I don’t know many basic things. actually I am trying to use a transparent window decoration (Polarnight -dark) but instead geeting the window to be transparent I am getting wide transparent edges (which is not same as shown in the preview for this window decoration), as you can see in the image.

Please help me getting correct this, Thank you.

What you call the edges are the window decoration. Therefore, installing a translucent window decoration gives you translucent window borders.

If you want the window itself to be translucent, then what you need to do is set the application theme to kvantum and install a translucent kvantum theme from You must download and unpack this theme and then point the Kvantum Manager to the folder with the unpacked theme.

For instance, this theme below is a kvantum theme called Glow Mojave Dark. :arrow_down:

Thanks for the reply, but I have tried this method for sweet kde theme but still not getting translucent window.

as you can see in the image I am not getting the transluency on window in Dolphin

and this are my settings

It depends on the application in question. Not all applications support full translucency, but with a translucent theme, at least some parts of the window will then still be translucent.

Also, kvantum themes only work with Qt-based applications. GTK-based applications ─ e.g. gimp and pamac ─ have their own separate theme settings, and to the best of my knowledge, there is no support for translucency in GTK anymore, except maybe for the terminal window.

The bottom line is that not every window will look the same. In Qt-based applications, it all depends on which parts of the application window were designed to allow for translucency if a kvantum theme is used, and there is almost always going to be a difference in appearance between Qt applications and GTK applications.

The explanation I have given you above is the only way you’ll get translucent window contents in Qt-based applications, apart from Konsole, which allows for translucency all of itself (if properly configured).

ohk thanks again to give time for helping me but, isn’t Dolphin an Qt based application, if it so then Kvantum theme should work on it right ?

Yes, it is. I was merely giving you a general description of what to expect in terms of theming, given that you stated that you are new to GNU/Linux.

Just pick the regular kvantum theme. Then open up your browser to and find a kvantum theme to your liking. Click on the “Files” tab on that page and download the file ─ usually a .tar.gz file or something similar ─ into your home directory somewhere.

Extract the contents of the file with Ark or by way of the command line, and then fire up the Kvantum Manager from the application launcher. Point it at the folder with the extracted theme. :arrow_down:

By the way, the Sweet theme you’ve installed is not a kvantum theme. It’s only a window decoration.

I downloaded Polarnight-dark Kvantum theme and did same as you stated above, sorry to say but still the problem persists

Do you have translucency enabled in System Settings? :arrow_down:

Workspace → Workspace Behavior → Desktop Effects → Appearance

You may also need to tweak the settings in the Kvantum Manager itself, by the way. Note the checkbox for translucency in Dolphin. :arrow_down:

You’re using the proprietary Nvidia drivers (not nouveau), correct?

What rendering backend are you using for compositing?

You can check under System SettingsDisplay and MonitorCompositor

Actually I am using Proprietery Intel Drivers and my rendering backend is OpenGL 3.1

Ya Transluency is enabled in System Settings and I have the following settings in my kvantum manager :

The Intel drivers are not proprietary ─ they are GPL-licensed and they are part of the kernel.

What is your application style set to? :arrow_down:

System Settings → Appearance → Application Style

It must be set to just “Kvantum”, not any of the “dark” variants or whatever. Also, if you are using a global theme other than the default, it won’t work either.

ohk I was not knowing it (about Intel Drivers) :sweat_smile: and my application style is set to Kvantum dark.

Set it to just “Kvantum” ─ no “dark”. :wink:

still not working :confused:

Then maybe the theme you’ve chosen doesn’t support translucency. Mind you that many themes at are already old and unmaintained, and that Plasma has evolved a great deal over time.


but Sweet theme is a well maintained and updated theme, Ig may be there is some other thing behind this incorrectness .

Don’t think this will solve it but try to untick “allow applications to block compositing” and try. I am having the same problem. Blur was working fine but one day while tinkering with some settings it got changed somehow and I am unable to find what I had done that time. Let me know if you managed to solve it.
Also note that blur is working perfectly fine elsewhere like in menus,latte dock, terminal etc. The only problem is in dolphin, settings application, kvantum manager such apps.

Thanks for the help, but unfortunately not working and as you said that blur works fine with menus, latte dock, terminal etc and not with dolphin, settings and such apps, this is the exact scene in my case.

The only thing I can think of that would explain it ─ and this has been my suspicion all along ─ is that the theme itself does not support translucency. Not all kvantum themes do.