Getting Manjaro 64bit to boot on a 2007 iMac 7.1 with 32bit EFI

Hi all,

a friend gave me his iMac 24’’ from 2007.
I upgraded the machine from its original specs (https://everymac.com/systems/apple/imac/specs/imac-core-2-duo-2.4-24-inch-aluminum-specs.html) to 4GB RAM and a 250GB SSD, thoroughly cleaned the insides and replaced the thermal paste on CPU and GPU.
In short, it will never be an extremely snappy system but should completely suffice for office work, multimedia etc.

As its video card is not supported in recent kernels, I everything in cli until now. Booting any distro into the GUI results in funny geometric patterns on the screen, so cli it is for the installation.
The iMac has a 32bit UEFI but a 64bit CPU, which might be part of my problem.

Contrary to the description in the [HowTo] Installation of Manjaro on 32Bit EFI , 64Bit CPU Systems (https://forum.manjaro.org/t/howto-installation-of-manjaro-on-32bit-efi-64bit-cpu-systems/93848), I didn’t encounter any problems in booting the recent manjaro image manjaro-xfce-23.0.4-minimal-231015-linux65.iso that I dd’d on a stick.

So, I booted the live system and then followed [root tip] [How To] Do a manual Manjaro installation (https://forum.manjaro.org/t/root-tip-how-to-do-a-manual-manjaro-installation/12507) to the dot up to point 8. Bootloader (https://forum.manjaro.org/t/root-tip-how-to-do-a-manual-manjaro-installation/12507#h-8-bootloader-31).
Here, I failed to install the 64bit grub due to the iMac’s EFI being 32bit. Instead, I followed this guide (https://ubuntuforums.org/showthread.php?t=2287767) and ran

grub-install --target=i386-efi --boot-directory=/boot --efi-directory=/boot/efi --bootloader-id=Manjaro
update-grub

which finished without errors.

Now, when I unplug the boot stick and restart the computer, it does not boot into grub. Instead, I see a folder symbol with a question mark (https://support.apple.com/en-us/102601). A reset of the NVRAM (https://support.apple.com/en-gb/HT204063) didn’t change that.

When I turn off the computer, insert the Manjaro bootstick and press ALT on my windows keyboard, I can select the boot stick via the “EFI boot” symbol that appears, then select “Detect EFI bootloaders” in the following menu and can then choose between four bootloaders:

    • (hd1,gpt1)/efi/Manjaro/grubx64.efi
    • (hd1,gpt1)/efi/Manjaro/grub.efi
    • (hd1,gpt1)/efi/Manjaro/grubia32.efi (which I put there due to 4. Placed the bootia32.efi in the /EFI/BOOT folder on the Ubuntu Server installer USB stick. (https://ubuntuforums.org/showthread.php?t=2287767))
    • (hd1,gpt1)/efi/efi/Manjaro/grubx64.efi
      Options 1. and 4. lead me to a cli login of the local Manjaro installation, 2. & 3. are not able to boot.

So far so good, but I don’t want to have to use a USB drive to kickstart grub.

This is the partitioning:

lsblk -f
NAME   FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                           
├─sda1 vfat   FAT32       CC90-E8F2                             498,3M     0% /boot/efi
├─sda2 swap   1           6addd690-8c0c-4be0-8026-b3092ef03369                [SWAP]
├─sda3 ext4   1.0         e239e8fc-c0a6-4f18-9306-6e4c0be10e83   91,1G     2% /
└─sda4 ext4   1.0         4dea75b2-d20d-4ddd-a9ff-0fa2d404e6b5  110,7G     0% /home
sr0                                                                           

How do I make loading first grub and then bootloader 1 permanent and without the aid of an extra USB drive?

Sorry for the long text but I thought this might be able to help folks who might run into similar problems.

Thank you very much in advance,

DarthBongo

I’ll preface this by saying I don’t know if this will work on your machine. However, at face value, if the ESP from the USB is working the way you want it to, you could try copying its contents to the main ESP on your drive.

I’d suggest first archiving the original efi folder, saving it to another location, and deleting the original from the disk before copying the USB efi folder to that location.

hello darthbongo,

i’m not sure about your installation, i used a ordinary installation method but what i know is that you have to edit /etc/default/grub and uncomment

# Uncomment to disable graphical terminal
GRUB_TERMINAL_OUTPUT=console

to get the grub menu visible at startup at my imac 12,2. it’s worth a try cause i’m convinced that it is the same on all imacs regardeless of the generation.

Unfortunately, that did not change the problem.
I still had to plug in the USB drive to boot into grub. Then I could select the newly copied grubx64.efi but it didn’t boot and prompted me to grub rescue.
I will revert the changes.
Thank you for the suggestion!

Hello Olli,

I uncommented said line but that still left me with the blinking folder icon with the question mark upon reboot.

As it then boots grub from the USB drive as soon as I plug it in, might it be that I somehow screwed up the configuration of my file path for grub? I might have chosen the path to grub on the USB drive instead of the correct path on the SSD. How could we figure that out?

can you post the output of

lsblk -f

to see a little bit more detailed the partitioning

I updated the 1st post accordingly.

The simplest efi loader is refind - this should be able to load the kernel directly - thus skipping the whole grub #! …

Using codefence is one way of providing the link

either inline https://ubuntuforums.org/showthread.php?t=2287767

or block

https://ubuntuforums.org/showthread.php?t=2287767

Holy smokes, refind worked! Yeah!!
Thank you very much!

Although the problem is technically solved, I might document getting a GUI to work for posterity reasons.

Your effort is welcome → Contributions Tutorials

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.