Getting error while starting picom

Unable to start picom after changing the backend from xrender to glx

╰─ picom --experimental-backends --config $HOME/.config/i3/picom.conf
[ 12/02/22 12:17:12.951 parse_config_libconfig FATAL ERROR ] Error when reading configuration file “/home/user/.config/i3/picom.conf”, line 232: syntax error
[ 12/02/22 12:17:12.951 main FATAL ERROR ] Failed to create new session.

Here is my picom config file

@arch in line 232 make backend = 'glx';backend = "glx";

This correction started the picom but with some errors

picom --experimental-backends --config $HOME/.config/i3/picom.conf

[ 12/02/22 14:12:02.712 wid_set_text_prop ERROR ] Failed to make text property: vgit-dac85.
[ 12/02/22 14:12:02.712 register_cm ERROR ] Failed to set COMPTON_VERSION.
[ 12/02/22 14:12:02.849 x_fence_sync ERROR ] Failed to trigger the fence (X error 136 XSyncBadFence request 134 minor 15 serial 359)
[ 12/02/22 14:12:02.849 paint_all_new ERROR ] x_fence_sync failed, xrender-sync-fence will be disabled from now on.

Are you using picom or compton? Picom is meant to be the successor to Compton. Remove compton and any compton.conf and try again. Launch picom with picom -b.

Links

picom - ArchWiki

picom(1) — Arch manual pages

I don’t have any compton files
But anyways its working fine so i can ignore that error
Thnx for the help @ishaanbhimwal :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.