Getting error: "getsockopt: connection refused" when trying to open phpmyadmin

Hello and apologies if this is a basic question.

I followed the forum tutorial called how-to-install-apache-mariadb-mysql-php-lamp. Everything worked great then. When I tried to open phpmyadmin a few days later, I get the following error displayed in the browser:

dial tcp myIPaddress:80: getsockopt: connection refused

So far, I have already tried the following commands:

sudo systemctl enable httpd
sudo systemctl restart httpd
sudo systemctl status httpd

Here’s the output from the status:

● httpd.service - Apache Web Server
     Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; preset: disabled)
     Active: active (running) since Sat 2022-10-15 19:05:19 PDT; 24min ago
   Main PID: 7514 (httpd)
      Tasks: 6 (limit: 19043)
     Memory: 8.2M
        CPU: 160ms
     CGroup: /system.slice/httpd.service
             ├─7514 /usr/bin/httpd -k start -DFOREGROUND
             ├─7516 /usr/bin/httpd -k start -DFOREGROUND
             ├─7517 /usr/bin/httpd -k start -DFOREGROUND
             ├─7518 /usr/bin/httpd -k start -DFOREGROUND
             ├─7519 /usr/bin/httpd -k start -DFOREGROUND
             └─7520 /usr/bin/httpd -k start -DFOREGROUND

Oct 15 19:05:19 nick-pc systemd[1]: Started Apache Web Server.
Oct 15 19:05:19 nick-pc httpd[7514]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name using myIPaddress Set the 'ServerName' directive globally to suppress this message>>

Thank you for helping!

I’d love to know more about what happened, but after starting up the computer today, the localhost worked as normal. So I suppose, problem solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.