Getting Deep Rock Galactic to run reliably


I’m running Manjaro Plasma on my Dell XPS 13, which has a Core i7 7500U and an Intel HD Graphics 620 chip. I realize this is rather underpowered but I would like to run Deep Rock Galactic reliably on this machine. Previously I was able to run the game fine on Windows. Also, ProtonDB has a platinum rating for this game, so I was hoping to get this game working reliably.

So far, I am able to start the game if I use DX12 mode (DX11 does not work at all for some reason) and it somehow works. However, when I enter a game, I end up facing one of the following issues

  • The game simply hangs in the loading screen
  • I get a black screen when the game is about to start
  • The game freezes while I’m in a level playing. CPU utilization goes down significantly and I have to kill the game process

I’m not sure what else I can do to resolve these issues. Online searches didn’t seem to help. Does anyone know how I can view logs to see what’s going wrong/

I have also tried GE-Proton-7-35, and tried using a combination of the following launch options (I also have GameMode installed):
gamemoderun DXVK_ASYNC=1 %command% -nosplash -disablemodding -dx12

However that didn’t seem to help with anything.

I would like to run the game in DX11 mode, I think that would result in a more stable experience. But I couldn’t get it to start. Does anyone have any tips?