Getting black screen when booting manjaro sway installation usb

Downloaded manjaro sway iso, writed it to usb using rufus, when trying to boot i just get a black screen. Ubuntu and arch installation usb boots fine, with monjaro just a black screen. What to do? Secure boot is disabled

Verify the integrity of the downloaded ISO?
Use a different method of writing the ISO to USB?
I recommend Ventoy.

how do i do that?

just did it with etcher, same result

I won’t tell you what you can easily find out yourself.
There are checksums associated with each particular ISO …

If the integrity is compromised, this result will be the outcome no matter the method you use to write.

the checksumes match

I have zero experience with either of the tools you mentioned.
Ventoy comes with it’s own boot loader, which then, in turn, boots (one of) the ISO’s you can put on the USB.
Might give different results. IDK. :man_shrugging:

did same with ventoy, same result bruh

can’t help you then, bro

welp, any alternatives to manjaro then?(no arch or ubuntu)

yes, plenty :grin:
among other things this depends on what you consider to be an “alternative”

If your system has Nvidia GPU - don’t use proprietary driver - use the –unsupported-gpu flag