Getting a black screen after the latest update

I am getting a black screen after the latest update. I saw that it is a common issue that many can face and I tried some of the steps that were suggested in other posts but nothing seem to work.

Can someone help me get my login screen back?

Please see

How do you expect someone to provide with good information if all he is seeing is a black screen?

1 Like
1 Like

ctrl+alt+fn+f2 to get to tty2 and login there and edit here the output of inxi --admin --verbosity=7 --filter --no-host --width

1 Like

I had the same problem.
I solved it by downgrading xorg-server

to get to terminal:

to check your xorg-server cached previous versions:
ls /var/cache/pacman/pkg/xorg-server* (don’t forget about “*”)

to roll back:
sudo pacman -U path_to_wanted_package_to_downgrade (it’s to be one of previous cached versions)

if it won’t help, get all your upgrades list:
grep -i upgraded /var/log/pacman.log
and try another packages in the same way

This is unsupported behavior and likely the wrong answer.

1 Like

Same here. Everything worked last night and today I’m getting some black screen with a cursor that loops all over. Timeshifted back before the last upgrade and no problem. However, once the system is back and I update it it goes back again into the loop. Changed the boot to splash and grub menu to be visible to see what’s wrong. The last upgrade with kernel and nvidia drivers was alright but I don’t remember having another update last night.

edit: it seems that the Optimus Manager is the guilty party here and update from 1.4-1 to 1.4-3.

1 Like

check this post - Latest update to optimus-manager broke my GUI

optimus-manager causes many issues (thanks cscs for edit)

1 Like

ftfy :stuck_out_tongue_winking_eye:

Why it’s unsupported?

Neither downgrades nor a system in a state of ‘partial-upgrade’ are supported.

If you are a user advanced enough to handle these things and recognize them as a stop-gap and will manage them properly … well OK … thats a benefit of being empowered. But its also simply not how the system is supposed to work, and you should expect extra overhead both to enact this change and also to stay healthy after doing so.


I’m not advanced, I know almost nothing.

If I know that the cause of my problem (- sudden black screen with flashing underscore) is the last upgrade of xorg-server, how can I manage this situation to not to kill the system?

Is it true that if now I don’t upgrade anything in the system and I don’t install anything new at all until the problem of partial upgrading is solved, my manjaro is not gonna die, isn’t it?

Of course if your system is running, and continues running … nothing is going to magically change that.
There are rare cases where maybe something like you describe makes sense … but only in those cases, it is unsupported, and it by its very nature requires extra management to even be in the situation the first place, let alone going forward.
So … if it works for you … then … keep it this way and check on updates and keep a backup handy … but I also wonder if maybe there is an underlying issue that should be resolved instead…


there were no problems at all last night,
then I checked for updates,
there were a lot of them
I started updates, it took more time than usual (there was a heavy kernel update too)
after it ended it asked for restart
after restart computer had been booting for much more time than usual
but eventually desktop shown up (I was so glad it’s not dead)
maybe 5-7 minutes of work lasted and this black screen with flashing underscore arose
any further attempts to restart the system ended with stuck on “files… blocks…” black screen

then I tried to roll back some of last upgrades
kernel - it’s not worked, I upgraded it back
qt5-base - it’s not worked, I upgraded it back
filesystem - it’s not worked, I upgraded it back
when I downgraded xorg-server desktop came to life

I updated the system on Thursday night, rebooted and it worked on Friday morning and evening with kernel 5.15.7-1. I think the Optimus Manager was a separate update and I probably updated it last night(can’t remember it was a tough one) hence the black screen this morning.

1 Like

I just wanted to share one thing. I replied to the comment made by @admdb .

It is okay to give suggestions to someone but I don’t think it is a good practice to remove your comment. Newer people might get some good ideas on how to reply to forum posts.

and If some mod removed @admdb’s comment, then I would suggest “undeleting” his comment. That way, everyone else will have a better understanding

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.