Get external bluetooth speaker working

Kudos to Manjaro developers. This is the only distro that detected the wifi, and DVD. The MHWD sets Manjaro apart.

But I think the reason my Broadcom bluetooth is not detected is Qualcomm don’t support the chip except in Windows, as per this Git project GitHub - winterheart/broadcom-bt-firmware: Repository for various Broadcom Bluetooth firmware
for my BCM43142. I thought just using open source drivers would detect it and have tried to follow this AUR (en) - broadcom-bt-firmware-git but honestly, it’s beyond me. All I have done is download the snapshop, but have no idea where to go with it next.

What outputs do I need to post to get help on this?

OS: Manjaro Linux x86_64
Host: Aspire ES1-571 V1.00
Kernel: 5.15.2-2-MANJARO
Uptime: 10 hours, 31 mins
Packages: 1306 (pacman), 5 (flatpak)
Shell: bash 5.1.8
Resolution: 1366x768
DE: Plasma 5.23.3
WM: KWin
Theme: Breath2 2021 Light [Plasma], Breeze [GTK2/3]
Icons: breath2 [Plasma], breath2 [GTK2/3]
Terminal: yakuake
CPU: Intel i3-5005U (4) @ 1.900GHz
GPU: Intel HD Graphics 5500
Memory: 2140MiB / 3839MiB

With pamac you can create and install a package with:

pamac build broadcom-bt-firmware-git

or if you have cloned it, change the working dir to that folder and run it:

cd ~/path/to/broadcom-bt-firmware-git
makepkg -si

I cloned it from Github, but do not really understand what to do next. How do I get the system to redetect the bluetooth? Can you point me to a Archwiki page on it? Sorry but this is new to me.


Well in general it should work like that:

  1. open a terminal
  2. Install the firmware:
pamac build broadcom-bt-firmware-git
  1. remove/unload the current driver:
sudo modprobe -rfv btusb
  1. add/load it again:
sudo modprobe -v btusb
  1. Check if it is running without errors:
sudo dmesg | grep -i blue
  1. Configure bluetooth configs:
hciconfig --all

:notebook: I did not test that and have no bluetooth devices for testing.

1 Like

Thanks, your instructions worked. But the hciconfig is not found, so I am including the grep results to try and learn why?

sudo dmesg | grep -i blue
[ 23.173150] Bluetooth: Core ver 2.22
[ 23.173179] NET: Registered PF_BLUETOOTH protocol family
[ 23.173181] Bluetooth: HCI device and connection manager initialized
[ 23.173185] Bluetooth: HCI socket layer initialized
[ 23.173187] Bluetooth: L2CAP socket layer initialized
[ 23.173191] Bluetooth: SCO socket layer initialized
[ 23.507860] Bluetooth: hci0: BCM: chip id 70
[ 23.508857] Bluetooth: hci0: BCM: features 0x06
[ 23.524886] Bluetooth: hci0: manjaro
[ 23.524893] Bluetooth: hci0: BCM43142A0 (001.001.011) build 0000
[ 23.668901] Bluetooth: hci0: BCM43142A0 ‘brcm/BCM43142A0-04ca-2012.hcd’ Patch
[ 24.441012] Bluetooth: hci0: Broadcom Bluetooth 4.0 USB
[ 24.441026] Bluetooth: hci0: BCM43142A0 (001.001.011) build 0339
[ 31.773318] audit: type=1130 audit(1639334217.878:35): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg=‘unit=bluetooth comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
[ 32.092770] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 32.092778] Bluetooth: BNEP filters: protocol multicast
[ 32.092789] Bluetooth: BNEP socket layer initialized
[ 102.477550] Bluetooth: RFCOMM TTY layer initialized
[ 102.477564] Bluetooth: RFCOMM socket layer initialized
[ 102.477572] Bluetooth: RFCOMM ver 1.11
[22297.601625] Bluetooth: hci0: urb 000000000e37a582 failed to resubmit (2)
[22330.235025] Bluetooth: hci0: BCM: chip id 70
[22330.236023] Bluetooth: hci0: BCM: features 0x06
[22330.252026] Bluetooth: hci0: acer
[22330.252035] Bluetooth: hci0: BCM43142A0 (001.001.011) build 0339
[22330.253120] Bluetooth: hci0: BCM43142A0 ‘brcm/BCM43142A0-04ca-2012.hcd’ Patch
[22331.013027] Bluetooth: hci0: Broadcom Bluetooth 4.0 USB
[22331.013036] Bluetooth: hci0: BCM43142A0 (001.001.011) build 0339
[michael@acer Downloads]$ hciconfig --all
bash: hciconfig: command not found

Then I guess this tool is not installed or/and not needed. No idea :man_shrugging:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.