Genius Eye 110 not working

My Genius Eye 110 webcam is not working on Manjaro Gnome. I am running 5.9.16-1-MANJARO; the driver for this camera is pac207 which comes with the gspca module. It is installed, but Cheese will not recognize any camera, applications like Zoom recognizes the device as CIF Single Chip.
lsusb shows:
Bus 001 Device 015: ID 093a:2472 Pixart Imaging, Inc. CIF Single Chip

I’ve tried reinstalling the driver, but all my efforts have been futile. If anyone knows anything about this kind of issue, I’d appreciate any help or guidance.
Thank you.

Hi @pablom, and welcome!

I don’t know if this will resolve your problem or not, but kernel 5.9 is EOL.

I explained it here, where you can find more information, not 20 minutes ago.

Hope this helps!

Hi @Mirdarthos, thank you for your reply, I have updated my kernel, now running 5.10. The camera is still not working though.

1 Like

Hi @pablom,

Well, like I said, I wasn’t sure if it would help or not. However, I just found this for you wich actually might help:


You can also have a look at this:

I realise that’s Ubuntu but the procedure, if not the exact steps should be the same.

Edit 2:

After reading this page I saw that libv4l is in the extra repos:

$ libv4l
v4l-utils                                                                                                                                                                                        [Installed] 1.20.0-1  extra
Userspace tools and conversion library for Video 4 Linux

So, in theory, the solution, not the steps for the solution, should work for you as well. Do yourself a favour, and look at the above mentioned Arch wiki page. I suspect it’ll be very enlightening.