Generic photo icon in systray after update and other unusual things

Updated the system the other day and a few unusual things happened.

  1. No WiFi. I awoke today to find it miraculously fixed itself and I can now use WiFi.

  2. The Xfce Power Manager icon is now a white, generic “photo icon” and some of the functions of buttons in the system tray are not working as normal. Though right and left-clicking them seems to produce the normal behavior, all the items preceding that Xfce Power Manager “photo icon” in the tray don’t have the normal mouse hover feedback, like the underline, and their tooltips appear below the region which means they are drawn off the bottom of the screen (I can see only two-pixels-worth of the top of the tooltips, running along the bottom of that part of the screen. I can’t remember the normal operation of the Xfce Power Manager button but if I left-click it (its a generic “photo icon”) it does nothing, if I right-click, there’s a menu with “Presentation mode” and “Settings…”. Clicking those does work at least.

  3. The pamac-manager has a broken ‘Preferences’ screen, ie. there is no ‘Save’ button in the bottom-right corner of the Preferences window anymore so I cannot make changes to preferences in pamac-manager, and I need to make a change. The setting is affecting how I can update over the cli.

Yes, I made a mistake and used pamac rather than pacman. I normally (basically always) use pacman over the cli but tried to install a program from a pkg.tar.zst file and it started updating everything. I didn’t want to stop it. Regardless pamac-manager is now partly broken.

I tried uninstalling it so I could reinstall, with:
sudo pacman -R pamac-manager

…but all I got was:
error: target not found: pamac-manager

There is no man page for pamac-manager nor any info on it at wiki dot archlinux dot org . I assume its part of pamac but preferences still affect pacman. I was referred here by ToZ . Can I reinstall pamac with pacman without breaking stuff in some kind of bizarre infinate loop of uninstallage?

  1. If you say : it did not work and now it works → How can you think we could help you with that kind of information…
  1. Remove the plugin from the panel, uninstall the associated package, reinstall it…or change your icon theme with another.

  2. There is no “Save” button, it’s not required to save your preferences, just close the window. Then pamac-manager package does not exist, you can check either within…pamac itself or with cli pacman -Qs pamac

Yeah I was going to say “was there ever a save button ANYWHERE in Pamac at some point?”, because it most likely definitely never had any kind of save button. Anywhere.

Hi, thanks for getting back.

  1. I mentioned in case someone had a similar experience after updating. There have been timing related bugs in Manjaro XFCE

  2. Will try a theme change first, as that seem less destructive and move up from there. I can’t say I’ve ever (properly) removed an application like Power Manager from the Status Tray. If you want to outline that in greater detail I’m all ears. It will be a couple hours before I get to this at least.

  3. All I can say is this is Xfce, and an hour prior to the update I was clicking that Save button multiple times and now there is no ‘Save’ button and the settings that I change go ignored. It sounds like an Xfce thing so I’ll poke my nose over there. :slight_smile:

  1. This problem is persisting for a number of Status Tray Items. The icon that is used instead is a generic icon that is used when an icon cannot be found. Either a few icons have gone missing from Papirus-Maia unexpectedly, or they are not being fetched properly, or there is a “locale” related bug of some kind breaking gtk for these items. The problematic items are Power Manager and MSM Notifier. Though they are just the ones that I can see at this time.

  2. As I explained on the Xfce forum: If one goes to the pamac-manager Preferences > ‘Official Repositories’ tab, and attempts to change the ‘Use mirrors from’ option, it doesn’t seem to work. Try changing it and closing the dialog and reopening it. It will not be changed. This screen did have a Save button previously I can guarantee that, and pressing Save did work. Even if the other tabs in Preferences did not, this tab did have a Save button, for whatever reason.

On the Xfce forums (viewtopic.php?id=14836), ToZ informs me the Manjaro team are developing pamac-manager. So here’s hoping we can get to the bottom of it.

The issue with the Power Manager icon was reported upstream to Xfce and has this reponse

no tray icon (xfce4-power-manager 1.7.1) (#104) · Issues · Xfce / xfce4-power-manager · GitLab

As a general note: if you’re using the xfce4-panel don’t use the trayicon. It’s really the legacy option I left in to potentially enable users of other or mixed desktop environment setups to use xfce4-power-manager.

The panel plugin shouldn’t have this regression.

ISSUE 1) (see top of page) The problem with the WiFi not working has not gone away by itself as I thought it did. It seems to not connect to WiFi for a couple of days after rebooting (EDIT since updating).

ISSUE 3) Is anyone with Xfce able to reproduce this in pamac’s GUI? You can’t change the mirrors, yes?

ISSUE 2) Thanks kindly for finding this @nikgnomic . I’m humbled to see it’s a common issue. I’ve tried twice to register on the Gitlab but it doesn’t seem to verify the email.

Following the quoted response you’ve kindly provided above, the following responses followed:

PHILIP Müller: (…) So as I see it: Desktop PCs seem to got forgotten with this update.

SIMON Steinbeiß: No, there is a setting to disable the systray in the preferences dialog of xfce4-power-manager. Also, the systray will be hidden after restarting your session automatically if you add the plugin.

Desktops show a specific icon ac-adapter-symbolic, so no, they have not been forgotten.

PHILIP Müller: I see. However, wouldn’t it not been better to disable the function completely when xfce as session is running. In the settings menu I can enable it again, logout, and at relogin the tray icon is disabled. When I remove the panel plugin, it stays. Especially if you don’t have the panel plugin enabled from 4.14 you will face that bug.

There is no response to this and the ticket is still open.

If there is an Xfce dev here, I want to confirm with them that this is still a problem, two months later with a very basic install. The two options provided are not really fixes,

  • switching off ‘System try icon’ in the preferences, is not really a viable solution for people who want to maintain tray access to it.
  • requiring a person to go online and research that they should install a different plugin is not the right direction to go in either.

For desktops, I honestly think ‘System try icon’ in the preferences should be off by default, but maybe that is easier said than don’t a so there need to be a pathway towards installing the correct plugin by default, without any intervention from the user. Is this possible?

For further information, I want to inform that the icon ‘ac-adapter-symbolic’ is not the one that is being requested AFAICT. If it were I’m assuming that the file at location /usr/share/icons/Papirus-Dark/symbolic/devices/ac-adapter-symbolic.svg would be used because it is the default icon set (and I didn’t change away from the default), but having said that…

…running upower -d on my end reveals a current icon name of battery-missing-symbolic. I have svgs for this icon in almost every icon theme, including the default one I’m using. Also, switching themes doesn’t show any of them.

I’m looking forward to having this bug resolved.

Desktop users might still need a tray or panel icon to turn presentation-mode on or off

And the panel plugin preferences has an option to indicate when presentation mode is on


So replacing the system tray with the panel plugin is a better option for my desktop system
(But I would prefer to have it in another colour instead of orange)

Welcome to the forum :wave:

On some systems multibooting windows cripples some hardware, including network/wifi cards. Windows keeps the hardware in a ‘on’ status to boot up faster, are you multibooting windows? If so see if disabling fast boot (somewhere in power options) solves the wifi issue. If not then it would be good if you posted some info about your hardware as Yannssolo asked for.

Thanks for getting back to me on this. No MS Windows on this system. It’s a clean install of Manjaro with no proprietary drivers. As such (?) I don’t see any option for “disabling fast boot (somewhere in power options)”.

Unfortunately, yansolo has retracted his answer so I’m unable to read it.

I only mentioned this problem here originally in case others had a similar problem after updating but it seems this is a unique problem to my setup and I’m going to need to consult lists like this one (here’s hoping that it is complete), wiki.archlinux. org/index.php/Network_configuration/Wireless

Thanks for all your input and sorry if I caused any frustrations.

Quite right, yes @nikgnomic . A good reason to keep the item in the Status Tray, even for desktop computers.

It’s a nice feature to have the extra icon when using the newer plugin but this doesn’t really change what I’ve written on this topic. A choice needs to made as to how an upgrade is done so items don’t break.

I’ve just realised that the above is an Xfce issue so will mosey on down to their forum again, :P.

(Re the icon design, talk to the theme designer. I’m going to assume the orange icon acts as a warning that the screensaver is disabled. You’re probably right that it stands out too much, eg. the blue dot on the Package Manager icon is effective. My guess is this is a design challenge because the icon is already a bit complex.)

Still hoping to know whether anyone can replicate this easy-to-test issue. Ie:

pamac is a Manjaro specific application using pacman’s libalpm - so you won’t find any manpage on

Pamac v10.1.0beta-2 has no Save button in Preferences - changes are immediate.

Pamac uses pacman-mirrors to generate the mirror list. Pamac only allows one country in the selection list. Remember to click Refresh Mirrors after changing the option.

Pamac implements a mirrorlist timer which will rewrite your mirrorlist at specific intervals. Use systemctl to list when the timer executes

$ systemctl list-timers

pacman-mirrors is a Manjaro specific application and you will find no manpage on

$ man pacman-mirrors

pacman-mirrors allows for more fine grained control.

Pamac is three packages

  • pamac-common
  • pamac-cli
  • pamac-gtk

There is probably not - please raise an issue on the Xfce bugttracker or comment on the existing issue.

Thanks for getting back to me, and I will look into this, but please don’t rename this thread as you’ve done. Certain functions are broken. I cannot change the option in the mirrors list after the update.

Title has been changed as we do not accept shouting - that is writing using only uppcase.

The option is in windows OS, so no use looking for it elsewhere. Sorry that I was not more specific.

No worries, please feel welcome and keep asking questions and searching for solutions, that helps others and by extension yourself :slight_smile:

Thanks @linux-aarhus for the background on the working of pamac and who manages what. The man page for pacman-mirrors is one of the best I’ve seen lately too.

No problem, @Hanzel. Thanks for the clarification and appreciate the input.

I’m on Pamac 10.0.5-1, which I assume is the lastest non-beta version and it also has no save button. This is okay I suppose, but it doesn’t save the selected value anymore. I can select a different option like a specific country or ‘Worldwide’ and nothing will happen. Even when I click the ‘Refresh Mirrors List’ option, as you suggested.

As an aside, the pool of mirrors from all over the world always exists on the system, so I don’t see why one needs to hit ‘Refresh Mirrors List’ after changing the “Use mirrors from” option. They seem to be two different options to me. If they are part of the same function then to be consistent with the rest of the UI, it should be triggered automatically when someone makes a selection (ie. place a spinner to the left of the button, press it, change it to faded, and rewrite the button as “Refreshing Mirrors List…”.)

Having said all that I hit the ‘Refresh Mirrors List’ button also and it didn’t make the selection permanent so I’m still at a loss.

I’m familiar with the whole don’t use CAPS notion. The original title had some emphasis in CAPS. Ie…
Generic photo icon in systray and BROKEN FUNCTIONALITY after update

Read in context that isn’t shouting, but to remove the emphasis, maybe consider renaming to:
Generic photo icon in systray and ***broken functionality*** after update

I’d appreciate keeping emphasis because a couple things are broken, and when things break emphasis is needed. Many people have seen this post over the days and noone complained here, also. If I could be more specific I’d have said, “and BROKEN WIFI and PACKAGE MANAGER Preferences after update”, but that’s getting a bit long-winded. Most would probably prefer just “BROKEN FUNCTIONALTY”.

Thank you - I do put a lot of work in the pacman-mirrrors app.

The complete list exist - yes - but in a json data file - located in /usr/share/pacman-mirrors/mirrors.json and this functionality is probably the only place where Pamac does not save your change automagicly.

Because Pamac uses pacman-mirrors - when you select a country in Pamac - without applying the change nothing happens.

Only when you apply the selection - pacman-mirrors is called and a new file is created /var/lib/pacman-mirrors/custom-mirrors.json which only contains mirrors from the country selected - and the custom mirror pool is then used to write up-to-date mirrors to the mirrorlist - which resides in /etc/pacman.d/mirrorlist thus containing only the mirror(s) found to be up-to-date.

No emphasis needed - just a clear and respectful description of the issue.

Please read the forum rules on how to post - and any moderator are allowed to modify topics which do not abide to the rules on How to Post and how to avoid Ineffective Discussion.

Don’t over use emphasis - don’t use it to express your frustration - respect the community by using the language properly - think before posting - how would I perceive this if someone said to my face - would I be pissed because of the lack of respect - then rephrase your topic.

Excessive use of the various formatting options including emojis can be considered disrespectful - depending on the context and can in worst case make a topic or comment completely unreadable as the meaning disappears in disturbance.

E.g it is acceptable to use strong text to create simple short and precise headline followed by a newline with content related to the headline.

1 Like


Okay that’s actually good but it needs to be more obvious to the user. Rather than a green ‘Refresh Mirrors List’ button which doesn’t immediately feel like part of the option, maybe 'Save & Refresh Mirrors’ is how it could be written. Up until recently it was a simple ‘Save’ button, but I understand why this was renamed. It’s doing a bunch of stuff!

Does a person need to be connected to the internet to perform this operation? If they are not connected does it still switch to the country without refreshing the list’ from the net, thus uses the existing list until the next scheduled fetch? If a internet connection is vital the interface could provide feedback when it fails(?) to connect. My experience is the setting fails to change, whether I’m connected or not.

Agree. That emphasis is bad when overused but I think I used it well. It’s fine though everyone has their own style, and I’m not fussed by this new title. (EDIT: “unusual” is the correct spelling)

If no internet connection pacman-mirrors will not try to download data files and will fall back to generating a random mirrorlist.

Try searching the forum for keyword pacman-mirrors - you will see that when an issue is spotted it is usually fixed within a very short time frame.

For Pamac - you could create an issue at gitlab with your suggestion - for the button.

Thanks @linux-aarhus, for the explanation. I think it would be good to relay such info to the user, “Failed to connect. Mirror list randomized.” Yes, I think it’ll be good to open a ticket for that, for the sticky country setting, and for the 'Save & Refresh Mirrors’ wording.

It might be some time before I get around to it, though.


I knew that - my fingers are faster than my eye so my brain didn’t catch it.