GDM not login chooser Wayland X11 after the last upgrade

Hi all,

I just upgrade the last packages available and I found that here are the new nvidia driver 495.44 available and gnome 41.1. I checked all settings in /etc/gdm/custom.conf

# GDM configuration storage

# Uncomment the line below to force the login screen to use Xorg




# Uncomment the line below to turn on debugging

This one is set up in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3 apparmor=1 security=apparmor udev.log_priority=3 nvidia-drm.modeset=1"

gdm-plymouth 41.0+r15+g23ebe617-1 and libgdm-plymouth

With both packages only boot in X11 not showing the wayland session in the login screen. If I change to the other package available gdm 41.0+r15+g23ebe617-1 without plymouth only boot in wayland without the possibility to choose the X11 session. I tried different combinations unsuccessfully. Anyone have this issue? Could it be a bug?


You have to do this:

Hi again,

Thank you for your support. I tried and doesn’t work, only run with X11 and in gdm not show the possibility to choose Wayland.


The /usr/lib/udev/rules.d/61-gdm.rules might be a bit different now, and early KMS is a must in /etc/mkinitcpio.conf.
Let me try on my end in a couple of minutes and i’ll let you know. I have a similar GPU but did not boot Gnome for some time.

Update: It seems indeed the new content of the /usr/lib/udev/rules.d/61-gdm.rules for preventing older driver than 470 to run on wayland is actually affecting the 470 and 495 too. So, you have to replace the entire content of it with the one from the tutorial. After that you can run on wayland …

Not very happy with how it performs tho.

No way.

I tried everything without result.

Edited /etc/mkinitcpio.conf

MODULES=“nvidia nvidia_modeset nvidia_uvm nvidia_drm”

Edited /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash rd.driver.blacklist=nouveau doglevel=3 apparmor=1 security=apparmor udev.log_priority=3 nvidia-drm.modeset=1”

Edited /usr/lib/udev/rules.d/61-gdm.rules.

gsettings set org.gnome.mutter experimental-features ‘[“kms-modifiers”]’


sudo mkinitcpio -P



Nothing of it works. Any other idea? GDM keep without show the other session Wayland. Only run with X11.


Tip: When pasting terminal output on Discourse forums, one can either…

  • Use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):

    type or paste code here

  • Use HTML:

    type or paste code here

Please edit your post accordingly.