[GDM] freezes switching user

I have issues with gdm. To solve them, I had to downgrade to the 3.38 version. The issue is that when I am logged with a user and I switch to another user (without logout), I get to a gray password screen with keyboard, mouse, system frozen… impossible to alt+FX to a terminal. Only path is to is reboot.
I have an AMD, nvidia card (with nvidia driver) and running gnome. Not such a gdm issue with “nouveau” driver.

I switched to the testing branch but the issue is still there… so I stay with gdm downgraded in 3.38.
Any idea how to solve this? Should I report a bug on gdm issue tracker or is it manjaro related?

my system info:

  Kernel: 5.15.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=d2a60e7f-15db-4307-9a5e-74fb99738b1d rw
  Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7B89 v: 1.0
    serial: <superuser required>
  Mobo: Micro-Star model: B450M MORTAR (MS-7B89) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.D0
    date: 01/06/2020
  Device-1: hidpp_battery_0 model: Logitech K800 serial: <filter>
    charge: 70% (should be ignored) rechargeable: yes status: Discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M325
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: Discharging
  RAM: total: 23.49 GiB used: 3.54 GiB (15.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1592 high: 2689 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2689 2: 1293
    3: 1428 4: 1376 5: 1376 6: 1549 7: 2428 8: 1336 9: 1337 10: 1377 11: 1374
    12: 1549 bogomips: 81617
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
    cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
    fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm
    mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc
    nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse
    pse36 rapl rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap
    smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock
    syscall tce topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme
    vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM107 [GeForce GTX 750] vendor: Gigabyte driver: nvidia
    v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 26:00.0 chip-ID: 10de:1381
    class-ID: 0300
  Display: x11 server: X.Org compositor: gnome-shell driver:
    loaded: nvidia display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x572mm (40.0x22.5")
    s-diag: 1166mm (45.9")
  Monitor-1: DP-1 res: 3840x2160 hz: 60 dpi: 140
    size: 697x392mm (27.4x15.4") diag: 800mm (31.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 26:00.1
    chip-ID: 10de:0fbc class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 28:00.3 chip-ID: 1022:1457
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.11-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.42 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 689.33 GiB used: 442.57 GiB (64.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX500SSD1
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: R013 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD5000AACS-00ZUB0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1B01
    scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 39.17 GiB size: 38.31 GiB (97.79%) used: 32.63 GiB (85.2%)
    fs: ext4 block-size: 4096 B dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: d2a60e7f-15db-4307-9a5e-74fb99738b1d
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 272 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sda2 maj-min: 8:2
    label: N/A uuid: 54EB-7C68
  ID-3: /home/<filter>/pCloudDrive raw-size: N/A size: 5 GiB
    used: 3.36 GiB (67.2%) fs: fuse source: ERR-102
  ID-4: /media/BACKUP raw-size: 292.97 GiB size: 287.37 GiB (98.09%)
    used: 144.54 GiB (50.3%) fs: ext4 block-size: 4096 B dev: /dev/sdb2
    maj-min: 8:18 label: BACKUP uuid: b0bfe9a4-4cff-427e-a1e7-d93695106363
  ID-5: /media/DATA raw-size: 19.63 GiB size: 19.19 GiB (97.79%)
    used: 10.7 GiB (55.7%) fs: ext4 block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3 label: DATA uuid: 43657b21-054c-456b-86cd-e58a26328166
  ID-6: /media/DATA_P raw-size: N/A size: 19.19 GiB used: 10.7 GiB (55.7%)
    fs: fuse.gocryptfs source: ERR-102
  ID-7: /media/DIVERS raw-size: 164 GiB size: 160.43 GiB (97.82%)
    used: 122.66 GiB (76.5%) fs: ext4 block-size: 4096 B dev: /dev/sdb3
    maj-min: 8:19 label: DIVERS uuid: 2f135506-64a4-4223-a4b4-b6355d8f20d0
  ID-8: /media/MEDIA raw-size: 164.47 GiB size: 160.89 GiB (97.82%)
    used: 118.58 GiB (73.7%) fs: ext4 block-size: 4096 B dev: /dev/sda4
    maj-min: 8:4 label: MEDIA uuid: 4d89f883-8bde-4400-83ef-cff35705e218
  ID-9: /var raw-size: 8.79 GiB size: 8.59 GiB (97.72%)
    used: 2.78 GiB (32.4%) fs: ext4 block-size: 4096 B dev: /dev/sdb1
    maj-min: 8:17 label: Var uuid: 37cb3bab-e0ec-42d1-9cb0-1ef44a68d8f8
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
  Processes: 341 Uptime: 5m wakeups: 7 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1739 pacman: 1736 lib: 430
  flatpak: 3 Shell: Bash v: 5.1.12 running-in: gnome-terminal inxi: 3.3.11

Thanks for the support,

Please post your system info as outlined here:

thanks for the feedback. I updated my post with more inforamtion. Met me know in case I need to provide more details.

Downgrading packages is not supported and will cause issues. Manjaro is a rolling release distro, it only rolls forward. Packages are built on certain versions of libraries and are not backwards compatible.

The latest xorg-server and systemd packages should have solved issues like this. I would switch to the testing branch at least temporarily to see if that helps.

thats what I did.

  1. issue with the stable branch => issue present
  2. switching to testing => still issue
  3. downgraded the package gdm to the 3.38 => issue disappeared (I tried downgraded to a newer version but the issue was still there)
  4. updating testing to remain uptodate (and having gdm back to the last version) => issue
  5. downgraded gdm again => issue disappeared

I will test at each update. But right now, the issue is still present.


problem still present after last stable update. I had to downgrade again gdm to the 3.38 version…

1 Like