GDM don't show Wayland option (after follow different tutorials)

Hi, i tried following different tutorials and Arch wiki pages. It seems I’ve done everything needed, but still only see X11 session. I tried this several times in the last years, so the most possible problem is my mixed configuration. And the problem to have a hybrid system with Nivida and Amd Ryzen.

Is it possible to have wayland in this environment?
I have the last nvidia driver installed and the module at grub too

Thanks for any help (or opinion if it’s doable)

I had a similar situation but in a virtual machine. Host ran on Wayland but in the Manjaro guest VM, GDM would only log into Xorg. Never found out exactly why but I think this would most likely be a hardware issue (although I never used Nvidia). But wait and see what others have to say.

1 Like

Hello @deimidis :wink:

Take look at /usr/lib/udev/rules.d/61-gdm.rules. There are the rules which disable wayland. There are no rules set by the Manjaro team, but upstream by the developers.

Thanks! I read that this file exists, but always appear at /etc/udev/rules.d and I haven’t that on my system, so I thought it wasn’t there at all.

/usr/lib/udev/rules.d/ is the system path and will be overwritten on each upgrade. /etc/udev/rules.d/ is the path for custom rules or user modifications.

Thanks, I thought that without 61-gdm file in /etc/udev/rules.d, the symbolic link to /dev/null was useless, but it’s not.

Now I’m in wayland, thank you!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.