Gcc13 conflict with gcc12 during update

The update stops and I get the error message of a file conflict:

gcc13: /usr/lib/gcc/x86_64-pc-linux-gnu/lib/libgcc_s.so existiert im Dateisystem (gehört zu gcc12)
gcc13: /usr/lib/gcc/x86_64-pc-linux-gnu/lib/libgcc_s.so.1 existiert im Dateisystem (gehört zu gcc12)

gcc12 cannot be uninstalled:

  • das Entfernen von gcc12 verletzt Abhängigkeit ‘gcc12’ benötigt von cuda

I will provide further information if necessary. Any recommendations?

Type gcc12 into search.

Then remove gcc12, it was dropped from the repos.

Either way, any gcc package is only required to build packages, not a runtime dependency. The base-devel package depends on gcc, so you don’t need gcc13, either.

I had used the search before and tried this:
To remove them
sudo pacman -R $(pacman -Qqm)
Then run a full system sync
sudo pacman -Syu

The result was:

Error: The operation could not be performed (Conflicting files) (translated)
gcc13: /usr/lib/gcc/x86_64-pc-linux-gnu/lib/libgcc_s.so existiert im Dateisystem (gehört zu gcc12)
gcc13: /usr/lib/gcc/x86_64-pc-linux-gnu/lib/libgcc_s.so.1 existiert im Dateisystem (gehört zu gcc12)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

How can I remove gcc12?

how about
sudo pacman -R gcc
or, better
sudo pacman -Rns gcc
and if it depends on base-devel or something else like cuda - so be it, remove that as well
you can reinstall it afterwards

On a cloned drive I tried various ways to remove gccxx without success.
Removing cuda with
sudo pacman -Rns cuda
Removed cuda, gcc12 and gcc12-libs.
After that, the update ran without any problems. I didn’t have to reinstall Cuda. E.g. Blender continued to use Cuda. Everything was fine - problem solved - thank you for your support.

There are other problems with Cuda now. I know whether it has anything to do with this. However, I would no longer see removing Cuda as a solution to the gcc problem.

Is there another way to resolve the conflict with gcc12 and gcc13? So far removing gcc hasn’t worked.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.