GCC 10.2 source compile problem

I’m using testing branch of manjaro. I tried stable branch manjaro new insallattion. I cant compile GCC 10.2 source.

I tried gcc 11 git from aur. Result is same. I’m tried lots of think. I cant find solution.

My source: svntogit-packages/trunk at packages/gcc · archlinux/svntogit-packages · GitHub

Last makebuild message:

libtool: link: ranlib .libs/libgfortran.a
libtool: link: rm -fr .libs/libgfortran.lax .libs/libgfortran.lax
libtool: link: ( cd “.libs” && rm -f “libgfortran.la” && ln -s “…/libgfortran.la” “libgfortran.la” )
make[6]: Leaving directory ‘/home/user/Genel/gcc/trunk/src/gcc-build/x86_64-pc-linux-gnu/32/libgfortran’
make[5]: Leaving directory ‘/home/user/Genel/gcc/trunk/src/gcc-build/x86_64-pc-linux-gnu/32/libgfortran’
make[4]: Leaving directory ‘/home/user/Genel/gcc/trunk/src/gcc-build/x86_64-pc-linux-gnu/libgfortran’
make[3]: Leaving directory ‘/home/user/Genel/gcc/trunk/src/gcc-build/x86_64-pc-linux-gnu/libgfortran’
make[2]: Leaving directory ‘/home/user/Genel/gcc/trunk/src/gcc-build/x86_64-pc-linux-gnu/libgfortran’
make[1]: Leaving directory ‘/home/user/Genel/gcc/trunk/src/gcc-build’
make: *** [Makefile:1003: all] Error 2
==> HATA: build() içinde bir hata oluştu.

Why? gcc 10.2.0 is in the core repo, no need to compile it yourself.

If you’re going to be compiling things from source and using the AUR, you’ll need the base-devel group (includes gcc) installed:

sudo pacman -Syu --needed base-devel

I was install all base-devel package. I’m using two extra patches for gcc make difference for amd ryzen cpu.

“If you have a -march=znver1/znver2 processor and run x86_64 multilib, rebuilding the current GCC 10.2.0 would mean a nice performance boost with this patch”

Well, then you’ll need to adjust your CFLAGS in your makepkg.conf accordingly. See makepkg - ArchWiki

I tried all of makepkg page of ArchWiki. I cant find solution. I tried pure arch linux. Not solution.

You tried what, specifically? If you can’t provide detailed information, no one can provide detailed help.

I’m success.

I’m used virtualbox virtual machine. Installed Endeavour OS. I’m used Clean Chroot Manager.

Okay, it built successfully. But if you didn’t set your makepkg.conf correctly, it wasn’t built with the right optimizations and you would end up with the same thing the Arch gcc package provides.