Garbled SDL2 (mostly) application windows with kernel 6.6 + strange console grabage spewed

Hi all.

It is only by pure luck that I could attribute this problem of mine to the kernel but I’m not 100% certain there lies the issue. So here’s the initial context:

I have a Dell Latitude E6530 laptop that embeds two display cards with Optimus technology:

  • Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
  • NVIDIA Corporation GF108GLM [NVS 5200M] (rev a1)

Note that I have not installed any tool such as bumblebee or PRIME. I never ran into such an issue before I switched to Linux kernel 6.6.

When I boot my laptop with kernel 6.6.16-2 and run SDL applications, here’s how they appear:

In the mean time here’s what appears on the console (I ran the application from the command line):

:warning: The last two lines only appear because I quit the program. The console appears continuously flooded with garbage “log”-style messages and I have absolutely no clue where that comes from¹.

The window is just a simple graph plot. Here’s what it should have displayed instead:

And this is what should appear when closing the window:
(I ran this from a Linux mint installation before I figured out switching to an older kernel version doesn’t exhibit the issue.)

The Linux kernels that are installed on my system are versions 6.6.16-2 (the “broken” one) and 6.1.77-2 (the “good” one).

EDIT: I might seem obvious that there’s something wrong with my SDL2 installation but I also get those garbled results when I run glxgears.

I assume I did something wrong but I have zero clue as to what exactly. Any pointers as to what I shall check to sort that out?

Thanks for any hint/suggestion.

¹ If I had to guess, I’d say the application tries to display the window using “nouveau” and fails, obviously, which might explain the displayed noise and the console showing (flooding) messages tagged with “nouveau”. Apart from that, no clue.

Looks like you’re on the free nouveaux driver that’s known to cause issues, you should install the proprietary graphics driver for your card. And why not use optimus if your hardware allows it?

Please post one after the other the output of:
inxi -Fazy
mhwd -l
mhwd -li
(format each output using the ‘Preformatted Text’ </> button in the top row of your reply window)

Sure. Here goes:

$ inxi -Fazy
  Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/vmlinuz-6.6-x86_64 root=/dev/mapper/volumes-root
    rw net.ifnames=0 resume=/dev/sda2 quiet udev.log_priority=3
    mtrr_gran_size=16M mtrr_chunk_size=32M
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: light-locker vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro base: Arch Linux
  Type: Laptop System: Dell product: Latitude E6530 v: 01
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 07Y85M v: A01 serial: <superuser required>
    part-nu: Latitude E6530 uuid: <superuser required> BIOS: Dell v: A20
    date: 05/08/2017
  Info: model: Intel Core i5-3230M bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1199 high: 1200 min/max: 1200/3200 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1196 2: 1200 3: 1200
    4: 1200 bogomips: 20741
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166
    class-ID: 0300
  Device-2: NVIDIA GF108GLM [NVS 5200M] vendor: Dell driver: nouveau
    v: kernel non-free: series: 390.xx+ status: legacy (EOL~2022-11-22) last:
    release: 390.157 kernel: 6.0 xorg: 1.21 arch: Fermi code: GF1xx
    process: 40/28nm built: 2010-2016 pcie: gen: 2 speed: 5 GT/s lanes: 16
    ports: active: none empty: DP-1, DP-2, HDMI-A-1, LVDS-2, VGA-2
    bus-ID: 01:00.0 chip-ID: 10de:0dfc class-ID: 0300 temp: 49.0 C
  Device-3: Microdia Dell Integrated HD Webcam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.5:4
    chip-ID: 0c45:643f class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.11 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: intel dri: i965 gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: LVDS-1 mapped: LVDS1 model: LG Display 0x032c built: 2011
    res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel crocus drv: nvidia nouveau platforms:
    device: 0 drv: crocus device: 1 drv: nouveau device: 2 drv: swrast gbm:
    drv: nouveau surfaceless: drv: crocus x11: drv: nouveau inactive: wayland
  API: OpenGL v: 4.5 compat-v: 4.2 vendor: mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: NVC1 device-ID: 10de:0dfc
    memory: 999 MiB unified: no
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell 7
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0bea class-ID: 0403
  API: ALSA v: k6.6.19-1-MANJARO status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: off tools: pw-cli
  Server-3: PulseAudio v: 17.0 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e v: kernel
    port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
  IF: eth0 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0082 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IF-ID-2: virbr4 state: down mac: <filter>
  Info: services: NetworkManager, ntpd, sshd, systemd-timesyncd,
  Device-1: Dell BCM20702A0 Bluetooth Module driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-1.4:3 chip-ID: 413c:8197
    class-ID: fe01 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 4 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 status: discoverable: yes pairing: yes class-ID: 6c010c
  Local Storage: total: 931.51 GiB used: 291.17 GiB (31.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 2B6Q scheme: MBR
  ID-1: / raw-size: 40 GiB size: 39.2 GiB (98.00%) used: 22.87 GiB (58.3%)
    fs: ext4 dev: /dev/dm-2 maj-min: 254:2 mapped: volumes-root
  ID-2: /boot raw-size: 400 MiB size: 381.4 MiB (95.34%)
    used: 239.5 MiB (62.8%) fs: ext3 dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 300 GiB size: 295.11 GiB (98.37%)
    used: 111.66 GiB (37.8%) fs: ext4 dev: /dev/dm-1 maj-min: 254:1
    mapped: volumes-home
  ID-4: /tmp raw-size: 8 GiB size: 7.78 GiB (97.21%) used: 130 MiB (1.6%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0 mapped: volumes-tmp
  Kernel: swappiness: 10 (default 60) cache-pressure: 50 (default 100)
    zswap: yes compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 54.0 C mobo: 35.0 C sodimm: SODIMM C gpu: nouveau
    temp: 50.0 C
  Fan Speeds (rpm): cpu: 2773
  Memory: total: 8 GiB available: 7.63 GiB used: 3.79 GiB (49.7%)
  Processes: 262 Power: uptime: 2h 48m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 3.04 GiB services: upowerd,xfce4-power-manager
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1594 libs: 393 tools: pamac,yay pm: flatpak
    pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: screen inxi: 3.3.33
$ mhwd -l
> 0000:01:00.0 (0300:10de:0dfc) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0300:8086:0166) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Note: I removed escape sequences manually from the output.

Hmmmwell… because it’s known to be an immense pain in the b…¹ from the beginning, maybe?

¹ For which Linus Torvalds was famously, visually quoted for giving The Manufacturer the middle finger, right :wink: ?

I guess so :frowning: . Do you mind sharing a link about that one?

And by the way I wonder: why does it happen now ? I’ve been using many Linux distros on that machine for about ten years now, never had an issue until Linux kernel 6.6.

Erm… just… no. I’d rather disable the nvidia card instead, which I’d been for a few years. So does that mean there’s no solution for this laptop?

EDIT: Yay! and now I’m in a complete and utter mess :frowning: . I disabled Optimus once again aaand surpriiiiiiise! The graphics login manager no longer starts. I have other things to do than debug that right now. I’ll create another thread for that.

I used to be passionate about technology. Now I come to despise it by the day…

i would recommend to use kernel 6.1-lts if you’re in a hurry and check the issue later. btw. your laptop is an older one, there is no real cause to use the latest kernel while all your hardware-drivers are already included in the older kernel.

Check this post for a setup that seems to work on 6430 with Nvidia NVS 5200M using nvidia-390xx-dkms including a fix for Intel screen tearing issues.

That nouveau is not quite up to the nvidia drivers I know from experience with my 2009 mbp; at times no wake up from sleep, running hot, occasional crashes when watching video etc. It’s a workaround but, at least for me, not a solution.

If your experience with nouveau is positive and you do suspect the 6.6 kernel being the issue, especially if 6.1 works, I’d simply use ‘the good one’ and stay on that since it will be supported for longer than 6.6.

Thanks @Olli and @6x12 for your suggestions. Greatly appreciated, really. I’ll keep 6.1 so far indeed. My next issue is not being able to disabling the nVidia card again but at least I have some time until it becomes indispensable.

With that said, I’ll investigate the bumblebee setup when I have some time.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.