Gaming: CPU overheating while GPU not fully used

I have a Intel Core i7 CPU and a hybrid Intel/Nvidia GPU. I play on my external monitor, with the screen of my laptop as second screen (mainly to keep an eye on what my hardware does with Conky).

I’ve been trying to play The Finals on Steam for months now, but even with almost every video settings low the game crashes (freezes, so I have to go to Steam and stop it from there) several times an hour. I noticed that my CPU temperature is always 97°C while I’m playing, but I’m guessing it’s the max my sensors/Conky will display, and I suspect it is even higher.
My GPU on the other hand is never used to more than 75% of its capacity (still according to Conky) and is much cooler than my CPU (usually around 65°C).

Things I tried:

  • turning off my VPN (which I still do whenever I remember to do so, even though it’s not helping — because I realized it was silly to let it on while gaming);
  • tweaking power management settings (and indeed the more I go towards power saving the more it crashes — but even in “performance” mode I still have crashes);
  • as said above, lowering the graphics of the game: it helps, but it’s not enough;
  • adding gamemoderun %command% to the launch options of the game: no luck either;
  • playing with/without Proton Experimental (that’s recent, up until last week Proton was required);
  • rebooting and playing while making sure as few processes as possible were running in the background;
  • updating Steam, the game and my system over and over as updates come up;
  • reducing the FPS settings of the screen on which I’m playing, both in the game settings and in my system settings.

As you can see I did my best to hunt the issue… But I found nothing. All help will be greatly appreciated! Thanks.

Post your system plz:
inxi --admin --verbosity=7 --filter --no-host --width

Blind guess, clean your cooler? Additional replace heat paste?

Laptops are terrible for gaming… cooling will always be a big issue in a small papercase, there is terrible airflow… its just physics.

I hope you using your Laptop on a clean and flat table. Otherwise your heat issues accelerate.

You reducing your Hz from your Monitor and switching to Vsync to Limit your fps? If im translate this info right… this isnt a good move, better only use a FPS Limiter.

  Kernel: 6.6.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=ec15a0cb-e160-45c5-817d-ac46f45ca053 rw splash
    resume=UUID=898af67c-08f2-43d7-89cf-e29f0a5481fe udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Manjaro
    base: Arch Linux
  Type: Laptop System: Micro-Star product: Cyborg 15 A12VF v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-15K1 v: REV:1.0 serial: <superuser required>
    part-nu: 15K1.3 uuid: <superuser required> UEFI: American Megatrends LLC.
    v: E15K1IMS.30E date: 09/04/2023
  ID-1: BAT1 charge: 40.0 Wh (80.8%) condition: 49.5/52.0 Wh (95.2%)
    volts: 11.0 min: 11.4 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: discharging
  System RAM: total: 32 GiB available: 31.06 GiB used: 8.07 GiB (26.0%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 64 GiB slots: 2 modules: 2 EC: None
    max-module-size: 32 GiB note: est.
  Device-1: Controller0-ChannelA-DIMM0 type: DDR5 detail: synchronous
    size: 16 GiB speed: spec: 5600 MT/s actual: 4800 MT/s volts: note: check
    curr: 1 min: 1 max: 1 width (bits): data: 64 total: 64
    manufacturer: SK Hynix part-no: HMCG78AGBSA095N serial: <filter>
  Device-2: Controller1-ChannelA-DIMM0 type: DDR5 detail: synchronous
    size: 16 GiB speed: spec: 5600 MT/s actual: 4800 MT/s volts: note: check
    curr: 1 min: 1 max: 1 width (bits): data: 64 total: 64
    manufacturer: SK Hynix part-no: HMCG78AGBSA095N serial: <filter>
  Info: model: 12th Gen Intel Core i7-12650H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x430
  Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
    cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
    L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1400 high: 2185 min/max: 400/4600:4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2185 2: 2123 3: 2123
    4: 2104 5: 400 6: 2123 7: 2123 8: 400 9: 400 10: 2089 11: 400 12: 400
    13: 1608 14: 1768 15: 1635 16: 526 bogomips: 86048
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm pdpe1gb pebs
    pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good
    sdbg sep serialize sha_ni smap smep smx split_lock_detect ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip user_shstk vaes vme vmx vnmi
    vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves
    xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: HDMI-A-1,eDP-1 empty: none bus-ID: 0000:00:02.0
    chip-ID: 8086:46a3 class-ID: 0300
  Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile]
    vendor: Micro-Star MSI driver: nvidia v: 545.29.06
    alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ bus-ID: 0000:01:00.0 chip-ID: 10de:28a0
    class-ID: 0300
  Device-3: Bison HD Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3 chip-ID: 5986:211b
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x2160 s-dpi: 96 s-size: 506x570mm (19.92x22.44")
    s-diag: 762mm (30.01")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: top model: Dell SE2419HR
    serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: primary,bottom model: ChiMei InnoLux 0x1521
    built: 2020 res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.3.5-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a3 memory: 30.33 GiB unified: yes
  API: Vulkan v: 1.3.276 layers: 6 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 4060 Laptop GPU driver: nvidia v: 545.29.06
    device-ID: 10de:28a0 surfaces: xcb,xlib
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Micro-Star MSI
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:22be class-ID: 0403
  API: ALSA v: k6.6.16-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI RTL8111/8168/8411 driver: r8169 v: kernel port: 3000
    bus-ID: 0000:04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 931.51 GiB used: 502.85 GiB (54.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SFYRS1000G
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: EIFK31.6 temp: 28.9 C
    scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 897.05 GiB size: 881.9 GiB (98.31%)
    used: 498.27 GiB (56.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: ec15a0cb-e160-45c5-817d-ac46f45ca053
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: FFD2-7FF0
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 34.16 GiB used: 4.59 GiB (13.4%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 label: swap
    uuid: 898af67c-08f2-43d7-89cf-e29f0a5481fe
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-4:2 info: Lenovo Wireless Media Mouse type: mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 17ef:60d7 class-ID: 0301
  Device-2: 1-6:3 info: Bison HD Webcam type: video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 5986:211b class-ID: 0e02
  Device-3: 1-10:4 info: Intel AX201 Bluetooth type: bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 8087:0026 class-ID: e001
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 470 Power: uptime: 4h 31m states: freeze,mem,disk suspend: s2idle
    avail: deep wakeups: 1 hibernate: platform avail: shutdown, reboot, suspend,
    test_resume image: 12.41 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1722 pm: pacman pkgs: 1707 libs: 496 tools: pamac,yay pm: flatpak
    pkgs: 15 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: konsole inxi: 3.3.33

It’s clean; do you mean that I should add heat paste? Or are you asking if I have added any (in which case: no)?

Yes, and I’m even using a pencil to lift the fan grid a little higher above my wooden desk…

… should I?

Please tell me more!

Thank you for your answer.

Not add… but clean it and refresh your heat paste… and possible with a really good and expensive one… like Thermal/Cryonaut Grissly or how that paste ever called…

Also collect information what other Laptop Model buyers archive for Temps and try to copy the situations.

Reducing your Hz is terrible… only if you have above 144Hz, reducing to 120Hz is still good refresh rate, in this case v-sync is fine… but a real fps limiter is always better.

To be honest, i have no idea what the best way to limit your fps.

I heared in Protondb alot people using Mangohud and some people in this Forum told me to use strangle-git.

Install strangle-git from the AUR and you can launch your game by limiting the max framerate easily like that strangle 60 %command% for a Steam game (in its properties → launch options).

But i don’t like the idea to use more and more AUR Packages… i still hope to get a better option.

for max 60fps

DXVK_FRAME_RATE=60 %command%

and you can test

DXVK_FRAME_RATE=60 %command% -d3d11

or -dx11

You have a hybrid system.
Are you using PRIME?

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

Does this require to install additional package?

> glxinfo | grep 'renderer string'                                                        ✔ 
OpenGL renderer string: Mesa Intel(R) Graphics (ADL GT2)

> prime-run glxinfo | grep 'renderer string'                                              ✔ 
OpenGL renderer string: NVIDIA GeForce RTX 4060 Laptop GPU/PCIe/SSE2

@weingeist : what do you mean by:

? How do I test this? What command do I run in my terminal? Or is this supposed to be in my game’s launch options — in which case, what exactly should I write?


This is a Steam command, right click on a game in your library and properties, under start option you can use this command.

But it probably required MangoHUD, hey and im just see that MangoHUD is finally into the official repo… so you no longer need AUR for it.

Additional advise, you can also Under Volt your CPU or Disable the little cores (called E-Cores/Efficient Cores) from your Alder Lake CPU… The Power Cores are most of the time your goal for gaming… this little cores are only good for maybe hardcore power user stuff, like encoding videos and image processing.

When you deactivated this small cores in your Bios, you can also reduce the Vcore additional… but you better get more information when you really want to do Undervolting.

Is the game actually using the Nvidia card? If it’s using the Intel integrated graphics that would explain the CPU overheating…

Go to the game properties in Steam and put this in Launch Options

prime-run %command%

Any difference?

“…to better suit the size of laptop chassis, MSI has chosen to limit the RTX 4060 within the Cyborg 15 to a paltry 45W. That’s significantly less than the Gigabyte G5 KF, which runs its RTX 4060 chip at 75W.”
MSI Cyborg 15 (RTX 4060) gaming laptop review | PC Gamer .

No, you don’t need anything extra

1 Like

So, now I use the following launch options:

DXVK_HUD=full DXVK_FRAME_RATE=60 prime-run %command%

It does seem to hold better, and I could even crank up the graphics — first deconnection after around 50 minutes of playing, which is pretty good (compared to before!).

However, the CPU temperature (displayed by Conky) seems to be the same (97°C or more), so I can’t say for sure wether the changes mentionned above are due to these changes in my launch options… And, the crashes greately varied in numbers from day to day… So thank you for your answers, I’m confident that the improved things a lot, but I’ll wait a few days to make sure the issue doesn’t come back. If it doesn’t, I’ll mark this thread as solved!

If you werent using prime-run before then you werent using the nvidia.

Available in Proton Experimental (as of 2024/02/29)

Enabled nvapi for THE FINALS.

I wish someone could have told me earlier…

It’s been a few days now and the game worked quite consistently, crashing about once an hour (I played with a chronometer on so I could be sure how long it was between the crashes). I can play with maximum graphics. It’s amazing, thank you so much @MrLavender and @weingeist for your help!

I’ll mark this thread as solved, as I think crashing once an hour is a pretty big improvement already, and the remaining crashes might be related to something else. Below the launch options that I use now:

DXVK_HUD=full DXVK_FRAME_RATE=60 prime-run %command%


So after you ask for help and others help you, you go and mark your own post as a solution?

1 Like

Well the solution is spread over several comments, so I did the best I could: gathered them in a short, readable answer and mark that as solution. However if the helpers think, like you, that this is not the way, then I’ll happily change that and mark one of the most useful posts as solution. I never really know what to do when one of my threads reaches a solution through discussion and collective effort. sorry…

1 Like

I’ll mark the first mention of prime.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.