Games stutter when vsync is disabled

In Steam’s Proton some of my games stutter when i disable vsync, Dead Space wasn’t smooth despite running at 60 fps constantly disabling vsync made the game smooth but introduced stuttering, i need to turn vsync off without making the game stutter

Do you have some settings applied regarding Vsync in KDE itself? Try to mess with that. Maybe the kernel can also introduce issues.

If you refer to the compositor’s vsync it is enabled, i’m using kernel 5.11 i also played the game in kernel 5.10 and it was just the same

Try other kernel (5.4) and/or (both) other KDE settings.

When i was using kernel 5.4 back then my system would stutter randomly, regarding KDE settings what tweaks would you suggest?

I would suggest to disable vsync in KDE but the setting is gone, I guess since Plasma 5.21. Try automatic, or other ones. Also try kernel 5.4 even if you had issue one day.

It’s the automatic one that i’m using

The VSync issue seems to be a normal issue with that game

You can try GloriousEggroll’s Proton to see if that helps with anything.

You can also try PROTON_USE_WINED3D=1 %command% as a launch option, this will make it use OpenGL instead of Vulkan for that game. There is 1 game that I have to use this to make it work without issues.

I’m running kernel 5.4 right now and it stutters like hell, opening a program stutters, my games stutter like crazy, opening firefox makes everything stutter, the mouse pointer stutters just from loading Youtube in Firefox and my specs are pretty great, i have an i5 8265u intel uhd 620 and 8gb ddr4 ram