Games in Steam crashing when starting


Lately, I’ve been trying to start games on Manjaro, after deciding to try gaming on it for the first time. That’s because, for some reason, Windows started misbehaving after a clean boot and it’s been an absolute pain to get it to run, so I figured I could try to make games run in Manjaro (before resorting to a VM). However, every time I try running some games, they crash with no error messages. Up until now, I’ve tried to run Doom Eternal, Dark Souls III and Dawn of War - Dark Crusade, all of them crash in the same way I’ve described. Death Rally classic as well, but for some reason, Steam doesn’t download any data of the game. Some games that do run are Half-life, Terraria, FTL and Star Conflict.
Anyway, I’m using the runtime version of Steam, with native-steam installed as well and it hasn’t helped at all. Whenever I try to load a game, it goes from “Launching” to “Precaching Vulkan Shaders”, which just ends up with an endless loading bar. It gives me the option to skip it, but it doesn’t load the game, just says “Running” and then it just crashes with no error. I’ve tried different versions of Proton, guiding myself with ProtonDB, but none of the recommended versions of Proton work.
I know this thread describes something similar, but I don’t want to make another clean boot of Manjaro just to play games.
inxi output:

  Kernel: 5.10.36-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
  base: Arch Linux 
  Type: Desktop Mobo: ASUSTeK model: CROSSHAIR V FORMULA-Z v: Rev 1.xx serial: <filter> 
  BIOS: American Megatrends v: 2201 date: 03/23/2015 
  Info: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer rev: 0 cache: 
  L2: 2 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 64247 
  Speed: 2190 MHz min/max: N/A Core speeds (MHz): 1: 2190 2: 2694 3: 3300 4: 2720 
  5: 1882 6: 2121 7: 3222 8: 3965 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 460.80 
  bus-ID: 01:00.0 chip-ID: 10de:1c03 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: nvidia 
  resolution: 1920x1080~60Hz s-dpi: 69 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.80 
  direct render: Yes 
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus-ID: 00:14.2 chip-ID: 1002:4383 
  Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f1 
  Sound Server-1: ALSA v: k5.10.36-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.28 running: yes 
  Device-1: Intel 82583V Gigabit Network vendor: ASUSTeK driver: e1000e v: kernel 
  port: c000 bus-ID: 03:00.0 chip-ID: 8086:150c 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: TP-Link Archer T9UH v1 [Realtek RTL8814AU] type: USB driver: 8814au 
  bus-ID: 13-2:2 chip-ID: 2357:0106 
  IF: wlp6s0u2 state: up mac: <filter> 
  Local Storage: total: 1.47 TiB used: 349.57 GiB (23.2%) 
  ID-1: /dev/sda vendor: Western Digital model: WDS120G2G0A-00JH30 size: 111.8 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb vendor: Western Digital model: WD5000AAKS-00V1A0 size: 465.76 GiB 
  speed: 3.0 Gb/s serial: <filter> 
  ID-3: /dev/sdc vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-1: / size: 109.48 GiB used: 24.92 GiB (22.8%) fs: ext4 dev: /dev/sda1 
  Alert: No swap data was found. 
  System Temperatures: cpu: 21.4 C mobo: N/A gpu: nvidia temp: 34 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 274 Uptime: 2h 51m Memory: 19.45 GiB used: 5.33 GiB (27.4%) Init: systemd 
  v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1456 Shell: Bash v: 5.1.8 
  running-in: konsole inxi: 3.3.04

My steam library is in /sdc, which is formatted in NTFS. I’ve seen a thread that point to the format as a problem, but since some games do run, I figure that’s not the source of my problems.

When pasting terminal output, highlight it and use the Preformatted text </> button, not the Quote " button.

Alternatively, add three backticks ` above and below the text:


Please edit your post accordingly.

Using an NTFS partition can indeed cause problems with Proton games. The author of GOverlay created a little program that might help called NTfix available in the AUR (Arch User Repository).

Done and noted.

Works! Thank you.

1 Like

You can thank the author, @benjamimgois. I forgot he’s a member here.

Keep in mind it’s just a simple hack, not a solution. Eventually you should migrate your Steam library to an Ext4 partition. NTFS does not support file permissions.

1 Like

Good to know that NTfix is being usefull, It needs more disclore. I tried to make a article on Gamingonlinux but it was rejected for some reason.