Games ""feeling lag"" (choking/skipping frames)

I used to use Linux mint (used for 1 year) when i have buyed a computer with it and for personal reasons haved to change to windows, after 3 years using windows decided to go back to linux.

I tried Linux mint again (was super lag)
I tried ubuntu (hate that system forever, 3 days trying to install and even after that the system just keeping frozen)
I tried Kali linux (yes i tried to use kali was a casual desktop, i am retard i know it) (the system was freezing time to time)

After all this pain and suffering of trying to install linux in my pc i decided to use manjaro, i have heard that was a good for games and casual desktop and noobs like me. Now to the point, the system is running great and i love it, but a good part of my game keeping choking the most part of time, some of then i have “”“fixed”"" putting everything in low and using some lauch codes on steam but still bad.

The games that most suffered that was:

Don’t starve

My system info:
Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
Desktop: Xfce 4.16.0 Distro: Manjaro Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: TUF B360M-PLUS GAMING/BR v: Rev X.0x
serial: UEFI: American Megatrends v: 2401 date: 03/22/2019
Info: 6-Core model: Intel Core i5-9600KF bits: 64 type: MCP
arch: Kaby Lake note: check rev: D cache: L2: 9 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 44398
Speed: 4300 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 4300 2: 4300
3: 4300 4: 4300 5: 4300 6: 4300
Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia
v: 460.73.01 bus-ID: 01:00.0
Display: x11 server: X,Org 1.20.11 driver: loaded: nvidia
resolution: 1920x1080~75Hz
OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01
direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3
Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 01:00.1
Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.26 running: no
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: efa0 bus-ID: 00:1f.6
IF: eno1 state: down mac:
Device-2: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
v: kernel port: 3000 bus-ID: 04:00.0
IF: wlp4s0 state: up mac:
Local Storage: total: 938.97 GiB used: 88.65 GiB (9.4%)
ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-75WN4A1
size: 931.51 GiB
ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade
size: 7.45 GiB
ID-1: / size: 915.53 GiB used: 85.26 GiB (9.3%) fs: ext4 dev: /dev/sda2
ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat
dev: /dev/sda1
Alert: No swap data was found.
System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 51 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 226 Uptime: 6h 03m Memory: 15.55 GiB used: 4.35 GiB (28.0%)
Init: systemd Compilers: gcc: N/A Packages: 1080 Shell: Bash v: 5.1.0
inxi: 3.3.04 "

I know that i must have made something wrong because when with my old linux mint i was able to play games with a extreme good fps and performance.

Please help this little retarded.

OBS: I know that i have put a lot more information that it need to have in this post, but in another places when i asked question about ubuntu they said to me to give the most amount of information possible so people could understand better my situation. (also i write like a monkey because i am not fluent in english)

Please edit you post, select all the output of terminal command, and click the </> button to format it in a nice readable text block.

With that CPU and video card you shouldn’t have issues running your game, definitely not need to put all settings to low that’s for sure.

What do you call choking in your games? Do you have low FPS? Do you have stutters?


If its stuttering like for a second and then it plays fluid and stuttering again and repeat…probably is just shader compilation,that goes aways while you progress the game,I don’t play any of the games you mention but normally Steam compile shaders before the game start to avoid stuttering with the games.

1 Like

i always run the games with 250/300fps and i used choking because i dont know the word in english and the translator said that was the most similar, the game is like skipping frames, is just freeze and unfreeze really fast.

Yep thats definitely shader compilation,no need to worry about it,when every shader has compile you will not have stuttering anymore.

Check in Steam settings if you have this enabled to compile shaders before the game starts,normally is on by default

Then when you start the game should appear this window


Just don’t skip it to avoid stuttering.

1 Like

Or tick both boxes so you wouldn’t even have to wait before launching a game. It will process the shaders in the background when it feels like it, at Steam startup or after you leave your games.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.