Gamepad not working after starting game (and continues to not work even after the game is closed)

So the issue I’m having is, I recently bought Sunset Overdrive on steam but my PS3 controller isn’t working in game. It works fine normally (such as in Darksiders 2 and with steam big picture) but once I’ve launched the game, it stops functioning as it normally does until I reboot my PC. I have the controller connected via USB.

I’ve also noticed that once I’ve launched the game, if I hold down the PS button and move the right analog stick, it controls my mouse cursor on screen (which it doesn’t normally do). So it’s like opening the game is changing the controller’s configuration or something? Once the controller is in this state, pressing the PS button no longer opens steam big picture anymore either.

If I run “cat dev/input/js0”, it still detects keypresses. I’ve tried running “wine control joy.cpl” to test the controller after running the game and curiously, it detects the controller and keypresses as if nothing is up. However if I test the controller in Darksiders 2, it no longer works in game.

I’ve tried launching the game with “SDL_JOYSTICK_DEVICE=/dev/input/js0” set as a variable, which did nothing. I also don’t have xf86-input-joystick installed, which I have a feeling can cause similar issues to this.

I was going to try to get it working with Xboxdrv but I figured I’d ask here if someone knew what was going on before I tried?

My system info:

  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=8d472bfa-4b34-4eaf-b715-5c718414c5cf rw quiet apparmor=1 
  security=apparmor resume=UUID=42bb968f-6998-44d3-840a-e847820475c8 
  Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASRock model: B450 Pro4 serial: <filter> 
  UEFI: American Megatrends v: P1.50 date: 11/05/2018 
  Device-1: hidpp_battery_0 model: Logitech MX Ergo Multi-Device Trackball 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
  Device-2: sony_controller_battery_00:1b:fb:2b:ee:33 model: N/A serial: N/A 
  charge: N/A status: Full 
  Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 118220 
  Speed: 1889 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 
  1: 1888 2: 1999 3: 1884 4: 1891 5: 2125 6: 2018 7: 2194 8: 2195 9: 1885 
  10: 1894 11: 2137 12: 1934 13: 1889 14: 1884 15: 1950 16: 1939 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: XFX Pine driver: amdgpu v: kernel bus ID: 26:00.0 chip ID: 1002:67df 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") 
  s-diag: 1055mm (41.5") 
  Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 92 
  size: 531x299mm (20.9x11.8") diag: 609mm (24") 
  Monitor-2: DVI-D-0 res: 1920x1080 hz: 60 dpi: 94 
  size: 521x293mm (20.5x11.5") diag: 598mm (23.5") 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.38.0 
  5.8.18-1-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 26:00.1 
  chip ID: 1002:aaf0 
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus ID: 28:00.3 chip ID: 1022:1457 
  Device-3: Logitech [G533 Wireless Headset Dongle] type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-3:3 chip ID: 046d:0a66 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  bus ID: 22:00.0 chip ID: 8086:24fd 
  IF: wlp34s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus ID: 25:00.0 
  chip ID: 10ec:8168 
  IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 816.04 GiB used: 294.83 GiB (36.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Intel model: SSDSC2BW120A4 size: 111.79 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: DC32 scheme: GPT 
  ID-2: /dev/sdb vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: KC48 scheme: GPT 
  ID-3: /dev/sdc vendor: Samsung model: MZ7PA128HMCD-010L1 size: 119.24 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 8L1Q scheme: GPT 
  ID-4: /dev/sdd vendor: Samsung model: MZ7PA128HMCD-010L1 size: 119.24 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 8L1Q scheme: GPT 
  Supported md-raid types: raid0 
  Device-1: md127 type: mdraid status: active Components: 
  online: sdc1~c0 sdd1~c1 
  Info: raid: raid-0 blocks: 249722880 report: N/A chunk size: 128k 
  super blocks: 1.2 
  ID-1: / raw size: 94.30 GiB size: 92.32 GiB (97.90%) used: 49.01 GiB (53.1%) 
  fs: ext4 dev: /dev/sda2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.20 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 
  System Temperatures: cpu: 37.1 C mobo: N/A gpu: amdgpu temp: 44.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 768 
  Processes: 328 Uptime: 8m Memory: 15.63 GiB used: 1.79 GiB (11.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 
  pacman: 1484 lib: 468 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08

Look in Steam if Steam doesn’t apply some sort of override to your controller. It may be a combination of these configuration menu that mess up your controller support.

It may also be a specific game setting to change?

I would also try to not have the AUR package xf86-input-joystick for a test after removing/rebooting it.

//EDIT: seems like it is supported out of the box when I look into package game-devices-udev

cat /usr/lib/udev/rules.d/71-sony-controllers.rules

# Sony PlayStation DualShock 3; bluetooth; USB
KERNEL=="hidraw*", KERNELS=="*054C:0268*", MODE="0660", TAG+="uaccess"
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0268", MODE="0660", TAG+="uaccess"

# Sony PlayStation DualShock 4; bluetooth; USB
KERNEL=="hidraw*", KERNELS=="*054C:05C4*", MODE="0660", TAG+="uaccess"
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="05c4", MODE="0660", TAG+="uaccess"

# Sony PlayStation DualShock 4 Slim; bluetooth; USB
KERNEL=="hidraw*", KERNELS=="*054C:09CC*", MODE="0660", TAG+="uaccess"
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="09cc", MODE="0660", TAG+="uaccess"

# Sony PlayStation DualShock 4 Wireless Adapter; USB
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0ba0", MODE="0660", TAG+="uaccess"

Thanks for your response. I’ve just had a look in those settings like you suggested - and for whatever reason, when I open the settings menu, the controller started working again (in the settings menu, but not the game).

I then tried to have a look at the controller settings while in game (the steam ones in the shift+tab menu, not the actual game ones):

But it gave me this error:

So I went back into the main steam “controller settings” and enabled “Playstation Configuration Support”:

Then when I went into game again, the controller just worked - I didn’t need to change any other settings… Super weird.

Anyway, thanks for pointing me in the right direction. No idea why that made it work, but it did and that’s good enough for me.

I think it is because you’re using Steam in Big Picture mode.

I wasn’t using big picture mode, that’s just what those menus look like for whatever reason. After actually trying to play the game, it looks like that setting makes the PS3 controller act like a steam controller. Which does work, but feels super weird. It’s like the analog sticks have input lag.

I ended up trying xboxdrv, which did work better and eliminate the lag issue, though the analog sticks now feel jittery. To be honest it’s probably not worth the effort, this is the only game that has this issue so I’m just going to refund it.

Thanks for your help.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.