Gamemode package is broken? (Command not found)

[rabcor@Thulebox ~]$ gamemode
bash: gamemode: command not found
[rabcor@Thulebox ~]$ pacman -S gamemode
warning: gamemode-1.6.1-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) gamemode-1.6.1-2

Total Installed Size:  0,24 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                              [##########################################] 100%
(1/1) checking package integrity                                            [##########################################] 100%
(1/1) loading package files                                                 [##########################################] 100%
(1/1) checking for file conflicts                                           [##########################################] 100%
(1/1) checking available disk space                                         [##########################################] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
==> skipping timeshift-autosnap due skipRsyncAutosnap in /etc/timeshift-autosnap.conf set to TRUE.
:: Processing package changes...
(1/1) reinstalling gamemode                                                 [##########################################] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Refreshing PackageKit...
[rabcor@Thulebox ~]$ gamemode
bash: gamemode: command not found

autocomplete does finish the ‘gamemode’ command however it gives that error, also /usr/share/gamemode directory does not exist.

Have you tried gamemoderun?

Or the daemon: gamemoded.

Those commands do seem to be working, although i’ve never used this software before so i’m not sure if it’s working right or not.

$ gamemoded 
v1.6.1
Successfully initialised bus with name [com.feralinteractive.GameMode]...

The gamemoderun output looks a bit suspicious to me, but like i said, never used it before so maybe this is as intended?

$ gamemoderun 
SHELL=/bin/bash
SESSION_MANAGER=local/Thulebox:@/tmp/.ICE-unix/865,unix/Thulebox:/tmp/.ICE-unix/865
WINDOWID=106954834
COLORTERM=truecolor
XDG_CONFIG_DIRS=/home/rabcor/.config/kdedefaults:/etc/xdg
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
LANGUAGE=
LC_ADDRESS=is_IS.UTF-8
LC_NAME=is_IS.UTF-8
SHELL_SESSION_ID=06a0019b5f5f403cb9cc74938a785cec
DESKTOP_SESSION=plasma
LC_MONETARY=is_IS.UTF-8
GTK_RC_FILES=/etc/gtk/gtkrc:/home/rabcor/.gtkrc:/home/rabcor/.config/gtkrc
XCURSOR_SIZE=24
GTK_MODULES=canberra-gtk-module
XDG_SEAT=seat0
PWD=/home/rabcor
LOGNAME=rabcor
XDG_SESSION_DESKTOP=KDE
XDG_SESSION_TYPE=x11
SYSTEMD_EXEC_PID=728
XAUTHORITY=/home/rabcor/.Xauthority
MOTD_SHOWN=pam
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/rabcor/.gtkrc-2.0:/home/rabcor/.config/gtkrc-2.0
HOME=/home/rabcor
LANG=en_US.UTF-8
LC_PAPER=is_IS.UTF-8
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
XDG_CURRENT_DESKTOP=KDE
KONSOLE_DBUS_SERVICE=:1.74
KONSOLE_DBUS_SESSION=/Sessions/3
PROFILEHOME=
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
YAOURT_COLORS=nb=1:pkg=1:ver=1;32:lver=1;45:installed=1;42:grp=1;34:od=1;41;5:votes=1;44:dsc=0:other=1;35
KONSOLE_VERSION=220402
KDE_SESSION_UID=1000
XDG_SESSION_CLASS=user
LC_IDENTIFICATION=is_IS.UTF-8
TERM=xterm-256color
USER=rabcor
CUDA_PATH=/opt/cuda
COLORFGBG=15;0
KDE_SESSION_VERSION=5
PAM_KWALLET5_LOGIN=/run/user/1000/kwallet5.socket
DISPLAY=:0
SHLVL=1
LC_TELEPHONE=is_IS.UTF-8
LC_MEASUREMENT=is_IS.UTF-8
XDG_VTNR=1
XDG_SESSION_ID=1
QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
XDG_RUNTIME_DIR=/run/user/1000
LC_TIME=is_IS.UTF-8
QT_AUTO_SCREEN_SCALE_FACTOR=0
XCURSOR_THEME=breeze_cursors
GTK3_MODULES=xapp-gtk3-module
XDG_DATA_DIRS=/home/rabcor/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share:/var/lib/snapd/desktop
KDE_FULL_SESSION=true
PATH=/home/rabcor/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/opt/cuda/bin:/opt/cuda/nsight_compute:/opt/cuda/nsight_systems/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
KDE_APPLICATIONS_AS_SCOPE=1
MAIL=/var/spool/mail/rabcor
LC_NUMERIC=is_IS.UTF-8
KONSOLE_DBUS_WINDOW=/Windows/3
LD_PRELOAD=libgamemodeauto.so.0

But even if it is working i need the files from /usr/share/gamemode to be able to configure this software as described here: Gamemode - ArchWiki

Always read the projects README if you’re not sure how to use the program. See

That directory is not part of the package. Notice the ArchWiki article says, “Create and configure a gamemode.ini file…” There are three options for placing the file, it would be best to create the file in your home directory in ~/.confg/.

FYI, most users will not ever need to change any of the default settings so you most likely don’t need it at all.

1 Like

Oh i misread the wiki article… i was so sure it was telling me to copy it from /usr/share/gamemode to /etc or ~/.config. /usr/share is such an odd place to put a config file… /etc is right there after all.

My bad, and thanks!

And the reason gamemode doesn’t work is because it obviously isn’t a command…

Musta gotten out from the wrong side of the bed this morning… Neither of these are mistakes I should be making.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.