Game window stuck on "flip" on Nvidia

Gnome desktop
Bf1 game stuck on nvidia flip mode instead of blit so no Gsync and crazy amount of tearing.
gsync indicator is on “normal”
System is fully updated.
Other games work great with blit and gsync indicator is green.
There’s something really messed up with this game, when I switch to full screen the BF1 window starts to blink so fast it hurts to look at it.
If I restart the game it loads in full screen but no Gsync and has the tearing problem.

Tried to disable compositor before starting the game? SHIFT + ALT + F12

Key combination doesn’t seem to be doing anything, same result.
I managed to get the game to use Gsync in windowed mode after 2 system restarts but every 2 minutes it stops and I need to press alt tab or windows key + D a few times to get it to work again but again after 2 minutes it will stop working…
There’s something wonky going on here.

Anything updates the screen every 2 min? System Monitor?

You mean the app? it’s closed
It’s not exactly every 2 minutes, can be 5 minutes or 30 seconds.
I have 2 monitors which show as one x screen in nvidia settings, when gaming I disable the second one and other games work with gsync except bf1