Game states great FPS but I still see the micro-stuttering

I have AMD 5500XT 8gb card that produces a steady 60fps for my 60hz monitor with v-sync in my favourite game - Elder Scrolls Online via Proton Steam.

However, I have noticed that compared to Windows11 experience, it’s not so smooth. Foresty areas that are easy on the GPU are smooth, but those in big cities with lots of going on the screen are inferior and glitchy.

In Windows there’s no stuttering, it’s super steady and FPS number really represents the actual rate. In Manjaro it’s not. I tried without v-sync but it’s even worse.

Any advice what to check out would be appreciated. I use Mesa driver out of the box in Manjaro XFCE.

Probably a similiar to this: Nvidia RTX3070 auf Amd Rx7900 xtx. Performance Probleme

Solutions was: Remove amdvlk which is not mesa and a standalone vulkan driver from AMD.

from ProtonDB
Using Proton 7.0-6 because Proton 8.0-1 caused severe input lag at the time. Have not tried upgrading the Proton version yet.

Nope, I don’t have amdvlk installed at all. I opted for Mesa at the beginning of Manjaro installation.

Didn’t help either. Maybe it’s even worse with 7.0.6. I used Proton-Experimental.

The main culprit was the HDD.
Game for Linux was installed on my regular SATA HDD, should have been on M2 SSD.

Unlike what people said on reddit, ESO greatly benefits of being installed on an SSD.

If not, the game will have stutterings. And that’s why FPS remained high despite this effect - it wasn’t GPU related.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.