Game on Steam doesn't launch (Humankind)

Hey there!

So: The Situation

I’ve been wanting to play Humankind on Steam, thus i freshly installed it along with a new version of Proton (8.0-5). I tried launching the game, which first initiates a sync-to-cloud, which passes, and then goes on to launch the executable. Launch seems to be done for a second (I can reach Steams “Exit” button) before then immediately killing the game. Application does not launch at all.

Related Error Messages
After launching Steam through terminal, I received error messasges akin to;

ERROR: object '/home/luca/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/luca/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

I then found multiple threads on this forum, detailing that these Errors are to be avoided. Sadly, I only have these and one other one, which I can’t recreate right now. That is because after rebooting the system, I did not receive any more messages through terminal from Steam. Only this;[13145]: Running Steam on manjarolinux 23.0.4 64-bit[13145]: STEAM_RUNTIME is enabled automatically[13221]: Steam runtime environment up-to-date![13145]: Steam client's requirements are satisfied
tid(13274) burning pthread_key_t == 0 so we never use it

Fixes i’ve tried

  • Swapping Proton Versions
  • Checking ProtonDB for compatibility (it’s set to Gold)
  • Rebooting System
  • Reinstalling Steam
  • Log out/log in on Steam
  • using Family Mode in Steam/not using it
  • Installing lib32-vulkan-icd-loader
  • using PROTON_NO_ESYNC=1 %command% and PROTON_USES_WINED3D=1 %command% as launch options

I don’t think the problem is Proton itself regardless, but I’m also not an expert. Please let me know if I should provide any other info that may help.

Welcome to the forum! :wave:

Did you see the pinned topic in the Gaming category?

As well as:

Please post your system details as outlined above as well as edit your topic title to include the title of the game your asking for help about.

1 Like

Thanks for the fast reply!

As outlined, I’ve accessed ProtonDB, but hadn’t looked at PCGamingWiki - though it did not seem like I could find any help there. Other posts here didn’t seem helpful either, as mostly everyone had different specific issues.

System Info Output

  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=9d8deb70-94bb-4e47-a53f-324a04ba7cde rw quiet
    root=/dev/mapper/luks-7692304f-5a50-4b70-988d-dcbd3bd38164 splash
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP 250 15.6 inch G10 Notebook
    PC v: N/A serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 8B34 v: 61.22 serial: <superuser required>
    UEFI: AMI v: F.05 date: 04/21/2023
  ID-1: BAT0 charge: 39.7 Wh (100.0%) condition: 39.7/41.0 Wh (96.7%)
    volts: 12.9 min: 11.2 model: HP Primary type: Li-ion serial: <filter>
    status: full cycles: 42
  System RAM: total: 16 GiB note: est. available: 15.28 GiB
    used: 6.72 GiB (44.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
PCI Slots:
  Permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 13th Gen Intel Core i5-1335U bits: 64 type: MST AMCP
    arch: Raptor Lake level: v3 note: check built: 2022+ process: Intel 7 (10nm)
    family: 6 model-id: 0xBA (186) stepping: 3 microcode: 0x4119
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 593 high: 721 min/max: 400/4600:3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 562 2: 677 3: 653 4: 651
    5: 530 6: 482 7: 400 8: 632 9: 641 10: 507 11: 660 12: 721 bogomips: 59916
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm pdpe1gb pebs
    pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good
    sdbg sep serialize sha_ni smap smep smx split_lock_detect ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid
    waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Raptor Lake-P [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:a721
    class-ID: 0300
  Device-2: Chicony HP True Vision HD Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2 chip-ID: 04f2:b78f
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x071d built: 2021 res: 1920x1080 hz: 60
    dpi: 142 gamma: 1.2 chroma: red: x: 0.592 y: 0.369 green: x: 0.349 y: 0.557
    blue: x: 0.153 y: 0.110 white: x: 0.314 y: 0.329
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: 1920x1080
  EDID-Warnings: 1: parse_edid: unknown flag 2
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (RPL-U)
    device-ID: 8086:a721 memory: 14.92 GiB unified: yes
  API: Vulkan v: 1.3.264 layers: 4 device: 0 type: integrated-gpu
    name: Intel Graphics (RPL-U) driver: mesa intel v: 23.1.9-manjaro1.1
    device-ID: 8086:a721 surfaces: xcb,xlib
  Device-1: Intel Raptor Lake-P/U/H cAVS vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51ca class-ID: 0401
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: off with: pipewire-media-session
    status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Realtek vendor: Hewlett-Packard driver: rtw89_8852be v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0
    chip-ID: 10ec:b85b class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:3 chip-ID: 0bda:b85d
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
    status: discoverable: no pairing: no
  Message: No logical block device data found.
  Device-1: luks-7692304f-5a50-4b70-988d-dcbd3bd38164 maj-min: 254:0
    type: LUKS dm: dm-0 size: 459.84 GiB
  p-1: nvme0n1p2 maj-min: 259:2 size: 459.84 GiB
  Device-2: luks-d0b010b9-b95c-44de-b5a7-17be9e93ca24 maj-min: 254:1
    type: LUKS dm: dm-1 size: 16.8 GiB
  p-1: nvme0n1p3 maj-min: 259:3 size: 16.8 GiB
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 76.63 GiB (16.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL4512HBLU-00BH1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPS3NHAV temp: 30.9 C
    scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 459.84 GiB size: 451.55 GiB (98.20%)
    used: 76.63 GiB (17.0%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-7692304f-5a50-4b70-988d-dcbd3bd38164 label: N/A
    uuid: 9d8deb70-94bb-4e47-a53f-324a04ba7cde
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 448 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 02CD-0139
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 16.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-d0b010b9-b95c-44de-b5a7-17be9e93ca24 label: swap
    uuid: 530358fe-22e7-41e8-8ae2-88c5dd10f489
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-3:2 info: Chicony HP True Vision HD Camera type: video
    driver: uvcvideo interfaces: 3 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 500mA chip-ID: 04f2:b78f class-ID: fe01 serial: <filter>
  Device-2: 1-10:3 info: Realtek Bluetooth Radio type: bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1
    mode: 1.1 power: 500mA chip-ID: 0bda:b85d class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 63.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 0 fan-2: 0
  Packages: pm: pacman pkgs: 1468 libs: 356 tools: pamac,yay pm: flatpak
    pkgs: 0
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
  CPU top: 5 of 336
  1: cpu: 23.0% command: steamwebhelper pid: 18166 mem: 219.1 MiB (1.4%)
  2: cpu: 19.4% command: steamwebhelper pid: 18222 mem: 384.5 MiB (2.4%)
  3: cpu: 17.8% command: steamwebhelper pid: 19011 mem: 176.7 MiB (1.1%)
  4: cpu: 12.5% command: ./steamwebhelper pid: 18141 mem: 381.3 MiB (2.4%)
  5: cpu: 7.1% command: steam pid: 17910 mem: 252.5 MiB (1.6%)
  Memory top: 5 of 336
  1: mem: 700.1 MiB (4.4%) command: opera pid: 4449 cpu: 2.4%
  2: mem: 384.5 MiB (2.4%) command: steamwebhelper pid: 18222 cpu: 19.4%
  3: mem: 381.3 MiB (2.4%) command: ./steamwebhelper pid: 18141 cpu: 12.5%
  4: mem: 344.4 MiB (2.2%) command: plasmashell pid: 955 cpu: 0.5%
  5: mem: 336.0 MiB (2.1%) command: opera pid: 4491 cpu: 2.5%
  Processes: 336 Uptime: 4h 27m wakeups: 17995 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30

By the way, forgot to mention…

Those are not errors, that’s normal if one is using a 64-bit prefix as the 32-bit libraries will not be loaded. Please post the full output, not just what you think is relevant.

An HP Elitebook is definitely not going to be able to handle many games. I don’t think integrated graphics meet the minimum system requirements mentioned on the Steam page.

By the way, you forgot to…


Your system is in an unsupported state.
The kernel is EOL, and this could also indicate further system discrepancies.

(Please install, and boot into a supported kernel like 6.6, and remove 6.5, and sync/update)

Your BIOS is also out of date.
The most recent update brings ‘support for additional display panels’.
But the one before that includes security fixes and nvidia performance upgrades.

Which also begs a question - HP talks about an nvidia dGPU, but I dont not see one listed. :thinking:

The BIOS may not be related to your issue, but its probably worthwhile nonetheless.

1 Like

Ah, I missed that.

NVIDIA® GeForce® MX550 (2 GB GDDR6 dedicated) (Optional)

But optional. So it could very well not be present in this machine.
@Lucajiro it may be worth verifying if you are not sure … maybe check in BIOS if you have the dGPU disabled.

Thank you all for your generous help, I’ve replaced the kernel and will be updating my BIOS later.

I’ve looked at my old receipt from when I bought the Laptop; I now know that there is no GPU included. Some games still run with the integrated graphics, but certainly not Humankind.

Thanks to you all again regardless!
(Other games do run by the way, so I assume it must’ve just been a min. requirement-level problem.)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.