Fullscreen mode of Terminal Emulator isn't fullscreen anymore

Hi, in the past 3 days I’m noticing a certain weird behavior, at least compared to the its behavior until now, or until 3 days ago.

When I’m trying to fullscreen while I’m in Vim, a strange thing happens. The very bottom part of the fullscreen is “missing”. However, if I do “Maximize Window”, where my status bar is visible, the bottom part is fine. (My status bar is on the top).

However if I’m trying to Fullscreen on any other application, even the Terminal Emulator itself which is “xterm-256color”, fullscreen seems to work just fine.

I have tried to change keyboard shortcuts in my Window Manager settings under XFCE but it didn’t work. I have tried to Google, DuckDuckGo, etc. but I haven’t found anybody with a similar problem.

I have, of course, tried to restart a computer, but nothing happened.

I’m not sure what information I should additionally provide, but I’m willing to cooperate if someone could provide help.

I would’ve uploaded or linked two pictures of this description, so that you can have a better understanding of what is the problem, but I guess that is not permitted.

Thanks in advance.

Can’t reproduce… Please annotate the steps to do so.

Mine are: using xfce4-terminal

  1. vim file.txt
  2. Press F11 for fullscreen,
  3. Press : to enter command mode.
  4. I see the commands at the very bottom of the screen.

I, probably, wasn’t very clear in my post. Since I couldn’t post links, or since I thought I cannot post links because I’m TL0, I made a Reddit post and included links to pictures.

I can see commands at the very bottom clearly, there is not problem with that. The problem is that I can see things below the command mode. And those “things” are the background above which is my TE running Vim.

I hope I was more clear this time.

Edit: Forgot to post the actual link.


P.S. In the mean time I have tried installing other TEs, but no luck, unfortunately.