Full disk encrypted manjaro no longer booting after BIOS reset to defaults

I have a Lenovo Ideapad duet 3i convertible (Intel cpu, 4GB RAM, 64 GB flash storage) where I installed Manjaro XFCE as the only OS about a year ago with full disk encryption but with Secure Boot disabled in the BIOS.
This has been working fine since then and until yesterday.

Yesterday I tried to fix an annoying hardware/BIOS issue many Lenovo portables have that they drain the battery even when completely shut down.

On the Lenovo forum I found a post that suggested resetting the BIOS to default values would fix the issue, so I reset the BIOS to default values and then re-disabled Secure Boot as I didn’t use it and indeed it fixed the power drain problem.

The problem is that since the BIOS reset to default values Manjaro no longer accepts the password to decrypt the encrypted disk with Manjaro.

Basically I get the password prompt:
Enter passphrase for hd0,gpt2 (xxxxxxxxxxxxxxxxx):

then I enter the same passphrase as always (and which worked fine until before the BIOS reset) and then I get:

Attempting to decrypt master key....
error: access denied.
error: disk `cryptouuid/xxxxxxxxxxxxx' not found.
Entering rescue mode...
grub rescue>

I’m a bit stumped at this point, how could the BIOS reset to default values have somehow affected the disk encryption?
Since I’m not using Secure Boot the BIOS should have nothing to do with the disk encryption?

How can I get this to decrypt again?

Maybe the UUIDs changed along with the BIOS reset?
You are probably going to have to do something like chroot in.
I am not very familiar with the manual steps required for esoteric filesystems and/or encryption … but theres a guide on here somewheres …

Looks like this might be one

  • make sure that the Fn cap lock isn’t enabled
  • since it can’t seem to find the disk check your boot order, a reset to default will/can change that
  • check other boot options, older machines will sometimes default to legacy
1 Like


Fn Lock was enabled by default since the BIOS reset, I can’t believe it!

It really annoys me that the cheap devices don’t even have any caps/fn/num lock LEDs so it’s impossible to see their status.

Now that I turned Fn Lock off it stays off even after a power cycle.

Anyway I’m just glad that the thing is booting again.

Thanks for your help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.