Fujitsu Snapscan S510 scanner wont scan

ive bought a used fujitsu S510 documentscanner, since sane bosts to support it fully.

lsusb detects the thing flawlessly:

Bus 002 Device 006: ID 04c5:1155 Fujitsu, Ltd ScanSnap S510

sane-find-scanner outputs:

# sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.
  # Also you need support for SCSI Generic (sg) in your operating system.
  # If using Linux, try "modprobe sg".

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
found possible USB scanner (vendor=0x04c5, product=0x1155) at libusb:002:012
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

scanimage -L outputs:

device `fujitsu:ScanSnap S510:22022’ is a FUJITSU ScanSnap S510 scanner

Scanimage -T outputs:

Output format is not set, using pnm as a default.
scanimage: sane_start: Error during device I/O

i added to /etc/udev/rules.d/65-sane-missing-scanner.rules:

#Fujitsu snapscan S510
ATTRS{idVendor}==“04c5”, ATTRS{idProduct}==“1155”, MODE=“0664”, GROUP=“scanner”, ENV{libsane_matched}=“yes”

i have added to /etc/sane.d/fujitsu.conf

usb 0x04c5 0x1155

and deleted the very same again, since its a doubling…

i added my user to both the scanner and the lp group. added scanner to saned.

I disabled usb-autosuspend in tlp-ui.

i rebooted several times in order to be sure, settings would take effect. No luck so far…

how to get the scanner working ?

Have you tried with gscan2pdf or simple-scan? Both are in the official repositories and perform reasonably well.

yeah. tried gscan2pdf, skanlite, xsane and skanpage. all frontends fail with: i/o error.

Just gonna toss this in here: